Postfix will not load; master.lock file permission denied

Discussion in 'Server Operation' started by ca_mongrel, Aug 6, 2009.

  1. ca_mongrel

    ca_mongrel New Member

    I used the Perfect Server How To to create my SuSE 11.1 server months ago. I installed ISPConfig, then uninstalled it, but the directory structure largely remains the same.

    The Apache server works fine. Postfix has worked fine until a few days ago, when I "cleaned up" the /srv/www/web3 directory a little bit. I may have broken Postfix.

    Postfix no longer starts. Mail.err reports "postfix/master[4957]: fatal: open lock file /var/lib/postfix/master.lock: cannot open file: Permission denied".
    Permissions shown below (I am only showing relevant data (to my knowledge):

    /var/lib # ls -l
    drwx------ 2 postfix root ... postfix
    /var/lib # cd postfix
    /var/lib/postfix # ls -l
    -rw------- 2 postfix root ... master.lock

    I have tried changing permissions to root, all, and back to postfix as originally found, to no avail. I have tried creating a new maste.lock file (w/ touch) to no avail.

    I am considering a Postfix uninstall/reinstall if I can't fix this issue.

    Any ideas or help would be appreciated, as the uninstall & reinstall may not be as simple as I need at this time.
  2. falko

    falko Super Moderator ISPConfig Developer

    I'd simply delete /var/lib/postfix/master.lock and try again.
  3. ca_mongrel

    ca_mongrel New Member


    I renamed master.lock to bmaster.lock.orig; no joy. Postfix will not start, and the same message occurs.
  4. falko

    falko Super Moderator ISPConfig Developer

    What's the output of
    locate master.lock
    Did you disable SELinux?
  5. ca_mongrel

    ca_mongrel New Member

    SELinux & locate

    SELinux is disabled. "locate master.lock" result is "/etc/var/postfix/bmaster.lock.orig", my backup. There is now no master.lock file, and Postfix still will not start ("postfix status" reports that it is not running after a "postfix start" command).
  6. tester321

    tester321 Member

    Did you ever find a solution to this?

    EDIT: SOLVED using another thread here and some googling. Details here.

    I have this problem on a Debian server running ISPConfig2.

    (After tarring the OS, so it is not the fault of ISPConfig or anything. I verified permissions vs the server it was tarred from that is running just fine, but still no go)

    Postfix won't start and errors out with the master.lock permission error.
    Last edited: Dec 23, 2010

Share This Page