Problem adding more PHP versions (8.x) on older Ubuntu 18.04

Discussion in 'ISPConfig 3 Priority Support' started by jpcyrenne, Dec 13, 2023.

  1. jpcyrenne

    jpcyrenne Member HowtoForge Supporter

    Good day,

    I upgraded (Ubuntu 18.04.6 LTS (Bionic Beaver)) ISPConfig 3.2.10p1 to the latest ISPConfig 3.2.11p1

    I presently have php5.6. php7.3 and php7.4. Where php7.2 seems to be the base PHP install with this older OS.

    root@host:~# php -v
    PHP 7.2.24-0ubuntu0.18.04.17 (cli) (built: Feb 23 2023 13:29:25) ( NTS )
    Copyright (c) 1997-2018 The PHP Group
    Zend Engine v3.2.0, Copyright (c) 1998-2018 Zend Technologies
    with Zend OPcache v7.2.24-0ubuntu0.18.04.17, Copyright (c) 1999-2018, by Zend Technologies​
    In the past I've installed the other versions this way:
    root@host:~# history |grep php
    197 apt-get -y install php7.4 php7.4-common php7.4-fpm php7.4-gd php7.4-mysql php7.4-imap php7.4-cli php7.4-cgi php-pear php7.4-curl php7.4-intl php7.4-pspell php7.4-sqlite3 php7.4-tidy php7.4-xmlrpc php7.4-xsl php-memcache php-imagick php-gettext php7.4-zipphp7.4-mbstring php7.4-soap php7.4-common php7.4-opcache php7.4-mysql
    199 update-alternatives --config php
    200 update-alternatives --config php-cgi​

    This time it didn't work for 8.x - My client needs 8.1, 8.2 later).

    Everything goes well with:
    add-apt-repository -y ppa:eek:ndrej/php (I even tried apt-get install software-properties-common gnupg2 -y)
    apt-get update
    apt-get upgrade
    But when I run a simple command it doesn't work (same for 8.2 and 8.3)?
    root@host:~# apt-get install php8.1 php8.1-fpm php8.1-cli -y
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    E: Unable to locate package php8.1
    E: Couldn't find any package by glob 'php8.1'
    E: Couldn't find any package by regex 'php8.1'
    E: Unable to locate package php8.1-fpm
    E: Couldn't find any package by glob 'php8.1-fpm'
    E: Couldn't find any package by regex 'php8.1-fpm'
    E: Unable to locate package php8.1-cli
    E: Couldn't find any package by glob 'php8.1-cli'
    E: Couldn't find any package by regex 'php8.1-cli'​
    Any hints on how I can get this fixed? Looking for a quick win as the customer wants to start testing this Friday.

    I sure hope it's not an Ubuntu 18.04.6 issue. I only seem to see Jammy (22.04) and Focal (20.04) on the ondrej sury site.

    If it is, do you have another Repo you could recommend?
    Or would you have a Ubuntu style procedure to compile it like this I used to use back in the days:

    I understand it might be time to set up a new VM. There is no need for php5.6 anymore and the site is moving from 7.4 to 8.1.
    I even read this online : Ubuntu 18.04 end of life reached on May 31, 2023.

    I thank you in advance for your excellent support as I know this is more an OS than ISPConfig issue.

  2. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    Ubuntu 18.04 is end of life indeed. It might be that the PHP repo for it does not have the newer PHP versions available. I would strongly recommend to either upgrade the OS to 20.04 (and maybe immediately 22.04 after) or set up a new VM and migrate to it.
  3. jpcyrenne

    jpcyrenne Member HowtoForge Supporter

  4. till

    till Super Moderator Staff Member ISPConfig Developer

Share This Page