problem: cannot retrieve mail from postfix

Discussion in 'Server Operation' started by cliang, Mar 16, 2006.

  1. cliang

    cliang New Member

    hi guys
    I follow the perfect setup Fedora core 4 and install the Postfix With SMTP-AUTH And TLS. I found that I can send mail to remote user, however I can't receive mails through the evolution client of otherthings. In fact I found that the mails indeed are received and delivered in the user's maildir directory. What's more, If I use outlook under another workstation, I can't receive and send mails. Is there wrong with my mail client configuration? I use IMAP of the receiving option.

    Here is the
    queue_directory = /var/spool/postfix
    command_directory = /usr/sbin
    daemon_directory = /usr/libexec/postfix
    mail_owner = postfix
    inet_interfaces = all
    mydestination = /etc/postfix/local-host-names
    unknown_local_recipient_reject_code = 550
    alias_maps = hash:/etc/aliases
    alias_database = hash:/etc/aliases
    debug_peer_level = 2
    debugger_command =
    xxgdb $daemon_directory/$process_name $process_id & sleep 5
    sendmail_path = /usr/sbin/sendmail.postfix
    newaliases_path = /usr/bin/newaliases.postfix
    mailq_path = /usr/bin/mailq.postfix
    setgid_group = postdrop
    html_directory = no
    manpage_directory = /usr/share/man
    sample_directory = /usr/share/doc/postfix-2.2.2/samples
    readme_directory = /usr/share/doc/postfix-2.2.2/README_FILES
    smtpd_sasl_local_domain =
    smtpd_sasl_auth_enable = yes
    smtpd_sasl_security_options = noanonymous
    broken_sasl_auth_clients = yes
    smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
    smtpd_tls_auth_only = no
    smtp_use_tls = yes
    smtpd_use_tls = yes
    smtp_tls_note_starttls_offer = yes
    smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
    smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
    smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
    smtpd_tls_loglevel = 1
    smtpd_tls_received_header = yes
    smtpd_tls_session_cache_timeout = 3600s
    home_mailbox = Maildir/
    mailbox_command =
    virtual_maps = hash:/etc/postfix/virtusertable

    Please give me some suggestions.
    Appreciate much for your help.
  2. falko

    falko Super Moderator Howtoforge Staff

    If you want to send from a remote PC, you must enable "Server requires authentication." in your email client.

    Which IMAP daemon do you use? Please post the output of
    netstat -tap
  3. cliang

    cliang New Member

    can u get the information?

    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 *:imaps *:* LISTEN 21296/xinetd
    tcp 0 0 *:32769 *:* LISTEN 1939/rpc.statd
    tcp 0 0 *:pop3s *:* LISTEN 21296/xinetd
    tcp 0 0 *:mysql *:* LISTEN 20594/mysqld
    tcp 0 0 *:pop3 *:* LISTEN 21296/xinetd
    tcp 0 0 *:imap *:* LISTEN 21296/xinetd
    tcp 0 0 *:sunrpc *:* LISTEN 1921/portmap
    tcp 0 0 *:smtp *:* LISTEN 25798/master
    tcp 0 0 *:smtp *:* LISTEN 25798/master

  4. cliang

    cliang New Member

    I checked that I use the imap-2002d-3, so it can't support maildir.
    so I modified the, "home_mailbox = Mailbox", however it still the same.

    do u have some idea to configure this? or other info?


  5. cliang

    cliang New Member

    I solved it. After I changed that directory to default.

    :) Whatever, thanks!


Share This Page