Problem deleting a DOMAIN/WEB/DNS-entry from Server

Discussion in 'General' started by pinz0, Aug 25, 2006.

  1. pinz0

    pinz0 New Member

    hi! this is a pretty strange problem i want to post here :(

    history: i made an entry of a domain (a whole web + DNS/A-Record-entries) serveral weeks ago. i was just preparing the domain in ISP-config for the day i would tell my domain-registrar to switch tomy own Nameservers to make the domain available.

    several days ago, i deleted this domain in the ISP-config-panel (the reasons why i did this aren't really important...). i cleared the trashcan and the domain + DNS-entries dissappeared from the ISP-config panels. OK.

    so, today i wanted to create the web-services wthin ISP-config for the same domain again, but for some reason the ISP-config doesn't want to create the depending DNS-entries (A-records) for the domain. they just don't get listed in the DNS-manager next to all my other 8 domains.
    i thought that i might try to delete the domain trough the ISP-config panel again, just to check my server via command line if the web really was deleted. for any purpose the web + domain is still listed next to the other domains in my /home-directory (where i put all my webs).

    so, this is my problem in a nutshell: i can create a domain again on the server (that was already created by ISP-config before and also deleted) but the DNS-entries won't be created, if i create a web with the same domain again. i've really deleted everything from the panel and also emptied all trashcans including the trashcan from th DNS-manager.

    this might be a strange description of my problem, but i really can't retrace this strange behaviour of my system. :mad:

    does anyone had similar problems before??

    i really would be grateful for any information!
    best regards!
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please search for the domain in the dns manager with the search function. Can you create the dns record for the domain dairectly in the dns manager without using the "create DNS" checkboxes in the isp manager?
  3. pinz0

    pinz0 New Member

    actually i found the DNS-records with the search function, but it is impossible to delete them! something is pretty wrong here..
    maybe it has smthg to do with the ISP-config-update which i did a week ago?
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    I dont think so.

    Did you get any error messages when you try to delete the dns record?
  5. pinz0

    pinz0 New Member

    NO error messages. i search for the "unvisible"=not listed DNS-record in the DNS-Manager, find one, delete it and then it is still there when i search for the record again.
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Please check all recycle bin's in the dNS-Manager if the dns record is now listed there.
  7. pinz0

    pinz0 New Member

    really, i checked that –*all bins are empty.
    i search for the domain (masters) in the DNS Manager.
    it shows me the domain, but this domain isn't listed in the left collumn where usually all DNS-entries are displayed.

    5 minutes ago i tried not to delete the entry of this DNS-record but to edit it!
    it is not possible to edit the "lost" DNS-entry because ISPconfig says that i use a wrong IP-adress, which in fact isn't true.

    i can't delete or edit this DNS-entry and also can't create a new one for this specific domain.

  8. pinz0

    pinz0 New Member

    hey people, please help me!

    this problem isn't solved yet.
    i can't delete the SOA-entry because it isn't visible in the ISP-Config DNS-Panel, as the the whole DNS-information isn't visible! if i try to set a new Master-DNS for this one domain, then ISP-config tells me that this SOA-entry is existing!!! (???) :eek:

    this whole issue seems to be a bug.

    may i delete this entry via command-line somewhere??
    would be great to get some hints..
    thanks in advance.
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    You must empty the recycle bin in the dns manager!
  10. pinz0

    pinz0 New Member

    i've already posted that i have emptied every single trashcan that is in ISP-config available.
    the DNS-entry isn't listed in the DNS-panel, BUT (!!!!!!!) it is still there, because i can find it via the search-function in the DNS-panel.
  11. rmac

    rmac New Member

    Same issue

    I am using Ubuntu 6.06 LTS, 2.2.6 of ISP config.

    I am having the same issues with not being able to completely delete DNS records, SOAs, or sites. I am guessing that they are not completely getting deleted from the backend ISPconfig database.

    It seems that deleting the DNS records will pull the record from the active pri.domain. file in /etc/bind/, so I think the problem is in the data structure for the ISPconfig interface. ISPconfig.log shows no errors, other than the "You already created a domain (SOA Record) with the name <domain name>." Is there a script to rebuild the database, or is there somewhere else to look?

    Any help is greatly appreciated, and thanks for such a great tool, I look forward to having it up and running.

  12. till

    till Super Moderator Staff Member ISPConfig Developer

    Please login as admin and empty all recycle bins in the isp manager and dns manager module.
  13. rmac

    rmac New Member

    Problem solved

    Thank you for the quick response. It was the recycle bin in the DNS manager that I missed, and if you don't get both of them it will give you this error.

    Thanks again,

Share This Page