problem installing apt on fc4 using rpm

Discussion in 'Installation/Configuration' started by chipw, Dec 5, 2005.

  1. chipw

    chipw New Member

    I just set up a machine with FC4 and am following the instructions found here -
    On the 3rd page it shows this command -
    rpm -ivh [url][/url]
    When I run that command it starts to do it's thing, then quits with 4 missing dependencies -

    I thought that above command would install the app plus all dependencies. Evidently that is not true? I also tried the same command with the --allfiles paramater, but have the same results.

    So after all that failure I downloaded the .rpm file and put it in the /tmp directory, then switched into the /tmp directory and tried this command -
    yum -y install
    Which results in these 3 failed dependencies -

    I have attached a file of the results of the yum command.
    What am I missing or doing wrong?

    Attached Files:

  2. till

    till Super Moderator Staff Member ISPConfig Developer

  3. chipw

    chipw New Member

    I found the web site for yum and the faq and read the paragraph -

    "One relatively easy way to fix this is to remove whatever package "needs" the packages that are about to be upgraded/obsoleted and then reinstall that package after you have upgraded everything else..."

    So I used yum to uninstall rpm, answered the one question with yes and now yum no longer works. Crap. Oh well.

    I am doing a reinstall on FC4 to start over again. Then I'll check out the site you reference for the missing dependencies.

    What I don't understand is how can there be missing dependencies on a brand new install?
  4. falko

    falko Super Moderator Howtoforge Staff

  5. chipw

    chipw New Member

    Hmm, don't know why, just did, after a quick glance at the fc4 tutorial I don't see any obvious differences, and the box is running fine, so I guess all is well in the world after all.

    I did reinstall everything, it all works, and I used yum instead of apt, if I remember correctly the apt web page says it is being obsoleted.


Share This Page