problem installing mplayer in FC5

Discussion in 'Installation/Configuration' started by openbysource, May 12, 2006.

  1. openbysource

    openbysource New Member


    Today I try and install mplayer latest version on my FC5 and to my surprise it failed during make.
    The problem was
    In file included from libpostproc/postprocess.c:655:
    libpostproc/postprocess_template.c: In function 'do_a_deblock_MMX2':
    libpostproc/postprocess_template.c:2901: error: memory input 4 is not directly addressable
    make[1]: *** [libpostproc/postprocess.o] Error 1
    make[1]: Leaving directory `/home/deependra/MPlayer-1.0pre7try2/libavcodec'
    make: *** [libavcodec/libavcodec.a] Error 2

    I suppose that's because of no ffmpeg package on FC5 box.
    But I tried yum I didn't got ffmpeg from there and then tried but ffmpeg there needed so many dependicies and when I try and used --aid option the rpm command doesn't looked into the rpm's in the current directory for dependency resolution.

    Fedora core 5 i guess is a real mess.
    Any suggestion on how to solve this problem.

  2. falko

    falko Super Moderator Howtoforge Staff

Share This Page