Problem upgrading 2.2.17 -> 2.2.18, database empty

Discussion in 'Installation/Configuration' started by h00s, Oct 17, 2007.

  1. h00s

    h00s New Member

    (Argh, i'm sorry i missed the forum, please move it to proper forum,
    sorry again)

    Problem is, after upgrade I can't login to ispconfig and ispconfig database is empty (0 tables).

    I have no special characters in mysql password and upgrade worked always fine till now.

    I'm using Ubuntu 6.06.1 and it was mysql update before updating ISPConfig to 2.2.18, I don't know if that mysql update could be the problem.

    This is output of install:
    Connected successfully to db ispconfig
    Warning: mysql_fetch_array(): supplied argument is not a valid MySQL result resource in /root/install_ispconfig/install.php on line 692
    (same errors on lines 717, 807, 812, 822, 839, 1145)
    Restarting some services...
    ./setup2: line 1135: [: ==: unary operator expected
    Shutting down ISPConfig system...
    /root/ispconfig/httpd/bin/apachectl stop: httpd (no pid file) not running
    ISPConfig system stopped!
    Starting ISPConfig system...
    Syntax error on line 1072 of /root/ispconfig/httpd/conf/httpd.conf:
    ServerName takes one argument, The hostname of the server
    /root/ispconfig/httpd/bin/apachectl startssl: httpd could not be started
    Warning: mysql_fetch_array(): supplied argument is not a valid MySQL result resource in /root/ispconfig/scripts/lib/ on line 47
    No results found!ISPConfig system is now up and running!
    Congratulations! Your ISPConfig system is now installed. If you had to install quota, please take the steps described in the installation manual. Otherwise your system is now available without reboot.
    Can it be fixed?
    (I moved existing_db*.sql, home_admispconfig*.tar.gz, root_ispconfig*.tar.gz from /tmp to safe location)
  2. Ben

    Ben ISPConfig Developer ISPConfig Developer

    Hmmm normally this only happens, if an error occurs during installation, in this case I would the userdata for mysql is wrong, cause there is no valid ressource for a connection.... but i thought this would be fetched?

    Anyway you can rebuild you ispconfig database with your backup. Then I would just try to reupdate 2.2.18. but to avoid running in the same error, I would check if the root password defined for this is correct.
  3. h00s

    h00s New Member

    I checked root password and it's ok. I restored from backup, run install again and I get same errors :(

    I think this problems/errors has something with recent Ubuntu mysql update..
  4. chuckl

    chuckl New Member

    I upgraded 2 Ubuntu 6.06 systems with MySQL 5.0.22 installed, no problems at all.
    Apt-get update and upgrade done immediately before the ISPConfig upgrade, so it is the current Ubuntu repo versions.
    Check the connection to MySQL with mysqld perhaps? Maybe the database itself is having a bad hair day, or has a probelm in the ispconfig database.
  5. Ben

    Ben ISPConfig Developer ISPConfig Developer

    So you checked, that the mysql-data in /home/admispconfig/ispconfig/lib/ is correct?
    e.g. try with mysql -u xxxxx -p

    but on the other hand, if the script can not connect, it should die with an error and so not continue and it should be logged in /var/log/ispconfig_install.log.

    So I'd suggest either the db, the php tries to select does not exist, or the table "isp_isp_web" does not exist in the database.
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    The database format has not been changed from 2.2.17 to 2.2.18, so you can try to restore just the database and the new ISPConfig version should work with it. I know that thsi is not a solution for future updates on your system :(
  7. h00s

    h00s New Member

    Hi! I solved the problem. The problem was in my mysql configuration :eek: . Database worked but not mysql cmd utility which is crucial for ISPConfig install/upgrade.
    Here's how I fix it (after I fixed mysql):

    1. Installed 2.2.17 ver.
    2. Edited ISPConfig database and deleted all the data from tables (but leaving the tables)
    3. Restored database from database backup ISPConfig setup left in /tmp
    4. Restored /root/ispconfig and /home/admispconfig
    5. Installed/upgraded to 2.2.18

    And, it worked :)
    Thank you all for help

Share This Page