Problem: /usr/local/ispconfig/server/

Discussion in 'Installation/Configuration' started by alecksievici, Mar 22, 2010.

  1. alecksievici

    alecksievici New Member


    I have a problem with my ISPConfig Installation.
    For some odd reason my server starded crashing.
    After a little investigation after running the server for about 2-3 hours i noticed that i have more than a hundred lines like these:
    root     12393  0.0  0.0   2552  1036 ?        Ss   01:27   0:00 /bin/sh -c /usr/local/ispconfig/server/ > /dev/null 2>> /var/log/ispconfig/cron.log
    root     12394  0.0  0.1   2556  1060 ?        S    01:27   0:00 /bin/bash /usr/local/ispconfig/server/
    root     12397  0.0  1.0  30124 10904 ?        S    01:27   0:00 /usr/bin/php -q /usr/local/ispconfig/server/server.php
    My box is runinng Debian Lenny 5.0.4 and my php -v output is:
    PHP 5.2.13-0.dotdeb.0 with Suhosin-Patch 0.9.7 (cli) (built: Mar  4 2010 17:21:21)
    Copyright (c) 1997-2009 The PHP Group
    Zend Engine v2.2.0, Copyright (c) 1998-2010 Zend Technologies
        with the ionCube PHP Loader v3.3.11, Copyright (c) 2002-2010, by ionCube Ltd., and
        with Zend Optimizer v3.3.9, Copyright (c) 1998-2009, by Zend Technologies
    And this is what i have in my crontab:
    * * * * * /usr/local/ispconfig/server/ > /dev/null 2>> /var/log/ispconfig/cron.log
    30 00 * * * /usr/local/ispconfig/server/ > /dev/null 2>> /var/log/ispconfig/cron.log
    The issue is that all my ram is getting filled with those processes and then i get seg fault and a crashed server.

    A temporary solution was to comment the first line in my crontab.

    Anyone has any ideea what's going on? Thanks in advance.
    Last edited: Mar 22, 2010
  2. Fantu

    Fantu New Member

    your version is old, upgrade to the last for fix hundreds bugs, the 3.0.2 is very good

    zend optimizer with php 5.2.13? you are sure is compatible I know that have compatibility problem now on php>=5.2.12|5.3
    Last edited: Mar 22, 2010
  3. alecksievici

    alecksievici New Member

    I don't think the issue is that my ispconfig installation is old, it worked just fine until yesterday.

    I'll try to recompile another version of php and see if the problem persists.

    If anyone has other suggestions please post them.

    Thank you.
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Please upadat eyour ispconfig version as Fantu suggested. The reason for the problem is indeed php, but the problem that more then one process gets started if one died has been fixed in newer ispconfig releases. It is recommended that you keep your ispconfig up to date as ispconfig gets constantly improved.
  5. alecksievici

    alecksievici New Member

    Again, as i stated before, my ispconfig installation worked fine until yesterday.

    Anyway, i'll give you an update: after enabling debuging in
    and running
    as root i found an interesting output:
    There is already a lockfile set. Waiting another 10 seconds...
    After deleting the .lock file and enablig the cron, everything seems to be working just fine.

    LE: Well, i was wrong, again, there are a bunch of pids :(. I guess i'll just have to update, but it bothers me because it used to work, it can't break just like that...

    LE: It seems that those pids just closed. I guess server.php works when it wants. I never took the time to monitor this server and i guess it did these things before but i didn't notice.
    Last edited: Mar 22, 2010

Share This Page