Problem when saving site in ISPConfig 3.2.11p2

Discussion in 'Installation/Configuration' started by MSIU, Jun 6, 2024.

Thread Status:
Not open for further replies.
  1. MSIU

    MSIU Member

    When I try to edit a website on a server with Debian 12 in ISPConfig 3.2.11p2, after saving the change it does not take effect and /etc/apache2/sites-available/domain.tld.vhost.err appears in the virtualhosts directory.

    After typing apache2ctl -t -f /etc/apache2/sites-available/domain.tld.vhost.err I get this:
    However, the Apache error log does not contain any errors with MPM or problems or conflicts with modules and configuration. But Apache and the websites are running: The command apache2ctl configtest returns:
    Here are all the loaded modules: apachectl -M:
    I tried searching for more info but no luck. Couldn't there be a problem with some module or its settings and ISPConfig? Thank you very much in advance for the advice, I no longer know where the problem is or where to look for it.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    You can't test the config like that. To see the reason for the error on the shell, run:

    mv /etc/apache2/sites-available/domain.tld.vhost /etc/apache2/sites-available/domain.tld.vhost.bak
    mv /etc/apache2/sites-available/domain.tld.vhost.err /etc/apache2/sites-available/domain.tld.vhost
    apache2ctl -t

    if you do not see an error, then run:

    service apache2 restart

    as apache config test is only able to display some of the errors that make apache fail. You will see an error and apache will likely not start. If you can't fix the error immediately, then run:

    mv /etc/apache2/sites-available/domain.tld.vhost.bak /etc/apache2/sites-available/domain.tld.vhost
    service apache2 restart

    to revert to the last working config.
    MSIU, ahrasis and like this.
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    The screenshot you posted shows the exact opposite. The command worked perfectly, as it showed the reason for your error. That#s why you should always post the output (as you did now) to avoid such wrong conclusions that something did not work just because you do not know how to interpret the answer you got. And please do not hijack other threads, you have your own thread for the problem.
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Of course, as the mv is not there to show an error. an error is shown either after running apache2ctl -t or service apache2 restart

    I asked you to post in your own thread and not to hijack this thread. You posted again here. Use your own thread.
Thread Status:
Not open for further replies.

Share This Page