Problem with httpd.conf

Discussion in 'HOWTO-Related Questions' started by dagogert, Sep 5, 2009.

  1. dagogert

    dagogert New Member

    Hi there,

    When executing the script as described I encounter a problem with the httpd.conf file as it gives an error-message like:
    "Starting httpd: httpd: Syntax error on line 210 of /etc/httpd/conf/httpd.conf: Syntax error on line 1 of /etc/httpd/conf.d/ruby.conf: Cannot load /etc/httpd/modules/ into server: /etc/httpd/modules/ cannot open shared object file: No such file or directory [FAILED]"

    Although I followed al steps consequently something got wrong on the way. I appears that the file can't be found and is not on the server (I searched all of it, so that might be true).

    After that I tried to install the file manually but that does'nt seem to help as the file is still not there and/or not accessible.

    The big question is now what I can do to solve the problem.
    Who has the answer? Please help...


    Gert at [email protected]
  2. falko

    falko Super Moderator ISPConfig Developer

    What tutorial (URL) did you use?
    What's the output of
  3. dagogert

    dagogert New Member

    I've been using the URL ""
    In there I followed the link "" in order to prepare my virtual server. All directions have been executed as given. After that I tried to follow the rest for the installation of ISP Config 2 and there this problem came up.

    When I execute updatedb and locate it does'nt say anything in return. It executes the command and returns to the prompt afterwards. Does this give you more and correct info?
  4. falko

    falko Super Moderator ISPConfig Developer

  5. dagogert

    dagogert New Member

    With the yum-command it says "Allready installed" on all items and at the end "nothing to do". The complete line in the httpd.conf-file is placed and the chkconfig is executed allright (no return-messages). Then, when starting apache, it gives the error as described earlier. Then I disable PHP5 and move on to 12.2...

    There I execute the yum-command, wget the tar-file and unzip it. Even the ./configure is OK. So far so good. But when I execute "make" it returns an error:
    apachelib.c:149:warning: ignoring return value of chdir, declared with attribute warn-unused_result
    apachelib.c:154:warning: ignoring return value of chdir, declared with attribute warn-unused_result
    apachelib.c:374: error: OPT_INCNOEXE undeclared (first user in this function)
    apachelib.c:374: error: Each undeclared identifier is reported only once
    apachelib.c:374: error: for each function it appears in)
    make: *** [apachelib.o] Error 1

    And the rest of the script (like make install and further) can't be performed (anymore).
    Does this give you adequate info?

    Greets & Thnx

Share This Page