Problem with "Install VMware Server On A Fedora 7 Desktop"

Discussion in 'HOWTO-Related Questions' started by mauriceh, Sep 25, 2007.

  1. mauriceh

    mauriceh New Member

    Having followed the Howto:
    "How To Install VMware Server On A Fedora 7 Desktop" all went very well.

    VMWare just released a new version 3 days ago that even works with the current Fedora kernel with no patching or hacking.

    Having completed that I then rebooted into the Windows XP side of the machine.
    I followed the instructions to install VMWare converter:

    That went smoothly using C: "Disk0"

    I then made a Virtual machine.
    I followed the instructions, EXCEPT I saved the Virtual Machine to a network share on my Samba server.

    I then rebooted into Linux, copied the VM folder to my home directory.
    I ran VM Console, and Browsed to that and it saw the Virtual Machine.

    However, when I try and "Start" it, I get an error:
    "VMware Server cannot find the virtual disk 'WindowsXP.vmdk' or one of
    the snapshot disks it depends on.
    Reason: The system cannot find the file specified."

    Under the Virtual Machine Settings is the following:
    "Unable to get information for disk (SCSI 0:0)"

    Unable to open file "/home/maurice/WindowsXP/WindowsXP.vmdk": The system
    cannot find the file specified."

    Indeed, if I look in that directory, I do not find a file called :

    Instead I find a file there called "WindowsXP-s001.vmdk, and several others ending in 3, 4, 7, 9 and 10..

    Soo.. I am stuck.

    Any suggestions?
  2. tmick

    tmick New Member

    "I followed the instructions, EXCEPT I saved the Virtual Machine to a network share on my Samba server."
    "Instead I find a file there called "WindowsXP-s001.vmdk, and several others ending in 3, 4, 7, 9 and 10.."
    After reading the links it appears as though saving to the SAMBA server is the problem. Assuming the "several others" start with WindowsXP-s also, then my guess is when you saved it to SAMBA it organized the .vmdk file as different shares and split them up accordingly. My guess as far as fixing it would be re-do it and this time save it where Falco suggests and see if that works. The idea is to be in Linux and launch your windows in VMware and run windows and Linux at the same time, therefore making the SAMBA share un-needed. That would be my suggestion.
  3. mauriceh

    mauriceh New Member


    He DOES say:
    "and select the location where the virtual machine will be created. You can select a local folder, but VMware Converter will display a warning if the destination folder is on the system that is going to be converted. A better idea is to select a network folder, for example the Virtual Machines folder on the system where VMware Server is installed (e.g. your new Linux desktop)"

    So.. as the only way this Windows box would see the this "network folder" would be as a Samba share..

    What's the difference??

    In my case the Linux with VMServer is on the same machine as the WinXP Instance I am virtualizing, so having both running at that point is a little impossible!
  4. tmick

    tmick New Member

    Okay this is going to be kind of hard to explain so bear with me. When you save it to the VMWare server folder VMWare images then it is in a virtual computer. This means Windows thinks it's been launched and has full control over the main board, mouse, CPU, and so on. What really happened is the VMWare server has created a partition in Linux and mounted it so that Linux thinks the image is just a process being run by the VMWare server. Windows thinks it's in its own little world and Linux thinks it's just another process running in the background.

    With a SAMBA share the image gets put into separate shares as per Microsoft's SMB protocol. The easiest way I can think of to try to explain this is to say if you were to make C:\ a share and try to access it, the share would be split up into different directories like you are experiencing currently. If you have ever "mapped" a Network Drive in Windows you have probably noticed you map to a certain folder and not the whole Directory.

    Now there is a catch to this, or was a catch, when I tried this with other Virtualization software I needed a multi-core processor to get Windows and Linux to run at the same time. Because of the way threading works in most processors it was impossible to run both at the same time.

    I still stand by my suggestion of creating and saving the XP image in the folder suggested by Falco and see if it works as advertised.

    Let me know if you still have questions I will try my best to answer them or find a site that explains it more clearly.
  5. mauriceh

    mauriceh New Member

    Problem was a missing file

    Seems that when I copied over the .vmdk files, some were not copied.
    Don't know why, but having copied the missing ones it works.
    So, copying to/from a Samba share is not the issue, just copy not working completely.
    Now, on starting it up, Windows INSTANTLY "discovered" some hardware changes, and decided that this copy of Windows needs to be re-registered.

    Anyone have any workarounds for that?
    Other than calling the 800 number?

    Also, the mouse keeps "freezing" for a second or two, then resuming.
  6. falko

    falko Super Moderator ISPConfig Developer

    No, I think you have to call MS.
  7. mauriceh

    mauriceh New Member

    Best way to run Windows VM

    Thought so.. Thanks Falko

    Is it possible to run a VM from the original Windows install?
    The real goal here is a machine that does not have to be dual booted.
    Having 2 Windows instances on hard disk is pretty inefficient.
    Not to mention the Windows issues with the changed hardware, the license, etc.

    The lagging / jumping mouse is pretty weird too.
    This is an AMD X2 6000, dual core 3GHz, with 4GB RAM.
    Not exactly a slow platform.
  8. chuckl

    chuckl New Member

    The 'ready to smash it with a hammer after five minutes' mouse behaviour usually means you need to install VMWare Tools to the guest OS.
  9. mauriceh

    mauriceh New Member

    Yeah, just figured that out in the VMWare Server forums.

    So, Falko,mmm.. you listening?

    I suggest you edit your HowTo and add at the end:

    Once you have created and the first time you run your VM instance,
    be SURE to install the VMWare Tools:

    1) For Windows, start the instance machine
    2) Log in to Windows
    3) Once logged in, Alt-Ctrl to get back to the Linux X console.
    4) From the VMWare Server console, select the VM pulldown menu
    5) Select: "Install VMWare Tools..
    6) Return to the Windows VM instance with Alt-Ctrl
    7) You should see the VMTools Installer as it Autoruns from the virtual CD drive.
    8) Follow the prompts to install the VMTools software.
    9) Restart the Windows Instance
    10) Log in to Windows
    11) Right Click the desktop, select Display Settings.
    12) Adjust the screen resolution, color depth and refresh rate
    to something useful to you.
    I suggest that if you are running Xorg at a particular resolution,
    for example 1280x1024, that you set the Windows resolution to the same.
    That way, when you select full screen mode,
    it fills the screen at the right resolution.
    13) Select Display Settings - "Advanced" button
    14) Make sure the Hardware Acceleration slider is all the way to the right.
    15) Go to Start--Control Panel--Mouse
    16) Adjust the click speed to something suitable for opening items.
    17) Select the VMWare Tools tray item, and check the settings.
    Defaults are likely going to be OK.
    18) Save settings and exit.
  10. mauriceh

    mauriceh New Member

    Or install a Corporate Edition copy of Windows that does not use the freaking check!
  11. mauriceh

    mauriceh New Member

Share This Page