Problem with pureftpd and filezilla

Discussion in 'Server Operation' started by wirki, Jun 12, 2017.

  1. wirki

    wirki New Member

    Hello Goodnight.

    I have installed pureftp-mysql from this tutorial

    The installation is correct since I do a "service pure-ftpd-mysql status" and get active

    ● pure-ftpd-mysql.service
    Loaded: loaded (/etc/init.d/pure-ftpd-mysql; bad; vendor preset: enabled)
    Active: active (running) since lun 2017-06-12 23:29:33 CEST; 2s ago
    Docs: man:systemd-sysv-generator(8)
    Process: 9035 ExecStop=/etc/init.d/pure-ftpd-mysql stop (code=exited, status=0
    Process: 9050 ExecStart=/etc/init.d/pure-ftpd-mysql start (code=exited, status
    Tasks: 1
    Memory: 664.0K
    CPU: 46ms
    CGroup: /system.slice/pure-ftpd-mysql.service
    └─9061 pure-ftpd (SERVER)

    jun 12 23:29:33 vpsxxxxxx systemd[1]: Stopped pure-ftpd-mysql.service.
    jun 12 23:29:33 vpsxxxxxx systemd[1]: Starting pure-ftpd-mysql.service...
    jun 12 23:29:33 vpsxxxxxx pure-ftpd-mysql[9050]: Starting ftp server: Running: /
    jun 12 23:29:33 vpsxxxxxx systemd[1]: Started pure-ftpd-mysql.service.

    If I try to connect from the terminal to ftp everything is correct, the problem I have when I try to connect from filezilla that all the time I receive the message "can not connect to the server"

    In host I have put my domain, even tried with the IP of the server vps, in user and password, I have put those that e created in the database.

    Could someone help me find where I am failing?

    Thank you very much greetings
  2. Tuumke

    Tuumke Active Member

    What errors do you get in filezilla? Can you copy/paste the console log from filezilla?
    Also a cat /var/log/syslog | grep pure
    Could help us out.
  3. Tomislav Aurednik

    Tomislav Aurednik Member HowtoForge Supporter

    Check that you don't block the ports in your firewall. The tutorial link does not work so cant see how you installed it. If you force passive you'll have the port range in /etc/pure-ftpd/conf/PassivePortRange. There you have 2 numbers for the ports range. So in your ISPConfig firewall you have to add this 2 ports as "55010:55110" that's how you declare a range of ports.
  4. wirki

    wirki New Member

    I put the link I followed since the other did not work.

    Cat / var / log / syslog | Grep pure

    I have the following:

    Root @ vps338639: / # cat / var / log / syslog | Grep pure
    Jun 14 21:26:25 vps338639 pure-ftpd: (? @?) [ERROR] Unable to identify the local socket: Transport endpoint is not connected
    Jun 14 21:27:25 vps338639 pure-ftpd: (? @?) [ERROR] Unable to identify the local socket: Transport endpoint is not connected

    In filezilla this other, I think neither connects.

    Status: Resolving the radio frequency
    Status: Connecting to ...
    Error: Connection timed out
    Error: Could not connect to server
    Status: Waiting to retry ...

    Making from the server a
    Nmap -sT -O

    Root @ vps338639: / # nmap -sT -O

    Starting Nmap 7.01 ( at 2017-06-14 21:27 CEST
    Nmap scan report for (
    Host is up (0.00045s latency).
    Not shown: 989 closed ports
    21 / tcp open ftp
    22 / tcp open ssh
    25 / tcp open smtp
    53 / tcp open domain
    80 / tcp open http
    110 / tcp open pop3
    143 / tcp open imap
    443 / tcp open https
    587 / tcp open submission
    993 / tcp open imaps
    995 / tcp open pop3s
    Device type: general purpose
    Running: Linux 3.X
    CPE OS: cpe: / o: linux: linux_kernel: 3
    OS details: Linux 3.12 - 3.19, Linux 3.8 - 3.19
    Network Distance: 0 hops

    OS detection performed. Please report any incorrect results at
    Nmap done: 1 IP address (1 host up) scanned in 2.81 seconds

    This / etc / pure-ftpd / conf / PassivePortRange file on my server does not exist, only these are:

    Root @ vps338639: / etc / pure-ftpd / conf # ls
    AltLog DontResolve MySQLConfigFile PureDB
    ChrootEveryone FSCharset NoAnonymous TLSCipherSuite
    CreateHomeDir MinUID PAMAuthentication UnixAuthentication

    Let's see if I can help you more in finding out what is happening. If you lack more information I will be happy to facilitate it.

    Thanks you very much partners
  5. Tomislav Aurednik

    Tomislav Aurednik Member HowtoForge Supporter

    You need to create this file if you force passive. There're a few config files that you need to create for some options.
    It look's like it's a firewall or router problem.
    The 21 / tcp open ftp is only for connection for file transfer you need other ports. I had similar problem and I had the 21 port opend but not the other for file transfer and I couldn't connect with filezilla.

    Try disabling firewall and open ports on router and test it. Normally this tutorials work out of the box.
  6. wirki

    wirki New Member

    Hello again, I looked at the router and I have the firewall disabled. In case it was some port and activated the dmz on the Ip that is the filezilla. And still not connected.
    E looked at the ovh control panel which is where I have contracted the vps, and in firewall rules there is no written rule.
    I have other ftp connections from filezilla and they work correctly
    Last edited: Jun 15, 2017
  7. Tuumke

    Tuumke Active Member

    Try from you VPS host to do a ftp connection to itself. See if you can login then?
  8. wirki

    wirki New Member

    Hi, how can I do that? An ftp connection itself.
    From the ubuntu console connected to the server if I can access the ftp without problems, you mean that?
  9. wirki

    wirki New Member

    Finally choose to reset the server and reinstall everything from the beginning.
    And is already working.
    It seems that the problem is when I install the iredmail mail server.
    Because it was tested before installing it and everything worked, and once installed iredmail stopped working.
    To install iredmail use this link
    I do not see where the conflict is.
  10. Tuumke

    Tuumke Active Member

    Do you still have an issue or not?
  11. wirki

    wirki New Member

    Hi, if I still have the problem.

    Apparently if I do a clean installation without installing Iredmail it works everything correctly, but to which I install iredmail, pure-ftpd stops working, so I imagine the problem comes with some conflict with iredmail, which I do not know can be. Follow the link tutorial from my previous message.

    Thank you
    Tomislav Aurednik likes this.
  12. Tuumke

    Tuumke Active Member

    I dont think i can help you then since i dont use iredmail.
  13. wirki

    wirki New Member

    Ok, do not worry, thank you very much for your help.
    I'll try to find out what's happening to her.

Share This Page