Problem with suspended mode on Asus Zenbook duo

Discussion in 'Technical' started by Petr Bohac, Nov 28, 2022.

Tags:
  1. Petr Bohac

    Petr Bohac New Member

    Hi,
    I have a really weird problem. When I install Ubuntu or Zorin on my Asus Zenbook duo, everything seems to work fine, but when I close the lid or press the power button to go into suspend mode (I think) the second monitor won't turn off and the laptop gets hot and warm. I have the latest NVidia driver update, the latest Linux update, and the latest update of everything. There's nothing in the BIOS like "Sleep Mode" so I can't change any of those settings. I've given it to local IT support to check if I have any hardware issues, but they haven't found anything.

    Can anyone help me or has at least the same problem?

    Peter
     
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Laptops are tricky. Asus probably makes special drivers for Windows to make closing lid trigger suspend mode. As for power button, I would expect it to turn off the laptop, not suspend it.
    Does suspend work if you choose it from shutdown menu?
     
  3. Petr Bohac

    Petr Bohac New Member

    Unfortunately, suspend mode doesn't work from the shutdown menu either
     
  4. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Then it may be Linux can not suspend that device, so the closing lid trigger does not matter. Ask Asus if they provide Linux drivers?
    I use IBM/Lenovo Thinkpads, they are well supported by Linux.
     
  5. Petr Bohac

    Petr Bohac New Member

    I asked Asus about Linux support, but all I got was "This is a Windows laptop, use Windows." It's a very strange approach to their customers...

    And regarding drivers, I only found some unofficial ones that I haven't tried yet
     
  6. ahrasis

    ahrasis Well-Known Member

    To me Ubuntu Desktop is very much one of the best linux there are and in terms of functionality it should have the equivalent functions to Windows.

    I actually have an Asus Zenbook which is using windows 11 but haven't had Ubuntu install on it (via dual boot method).

    However, I used to see that function while using an Acer laptop so I think there should be settings to control that functions if that was not created automatically during setup.

    That Acer laptop has power failure that I haven't find time to send it for repair for quite some times now though.

    Try enabling all repos and third party if you haven't done so already, as there could be some proprietary drivers that your laptop may need to make it work decently like it works for Windows.
     
  7. Petr Bohac

    Petr Bohac New Member

    I think I should have all repos and third party enabled, unfortunately that does not solve my problem
     
  8. pyte

    pyte Active Member HowtoForge Supporter

  9. Petr Bohac

    Petr Bohac New Member

    Okay, I can't believe it, but I found a solution.

    First, I want to thank you guys for your help. Without you, I probably never would have solved this problem.
    So anyway, there is what help me. (These steps are what I did)

    1.
    Change this value
    IngoreLid=false
    in
    /etc/UPower/UPower.conf
    to
    IgnoreLid=true

    and in
    /etc/systemd/logind.conf
    change this:
    #LidSwitchIgnoreInhibited=no
    to this:
    LidSwitchIgnoreInhibited=yes

    2. NVidia drivers what am I currently using:
    > Using NVIDIA Server Driver metapackage from nvidia-driver-510-server (proprietary)

    3. Check the output of
    /sys/power/mem_sleep
    with
    cat /sys/power/mem_sleep
    It has to be
    s2idle [deep]
    when it is not, do this
    sudo -i
    echo 'deep' > /sys/power/mem_sleep

    That's all ;)
     
    Th0m, ahrasis, Taleman and 1 other person like this.

Share This Page