problem with vmware-image on an already running server

Discussion in 'Installation/Configuration' started by vistree, Aug 21, 2006.

  1. vistree

    vistree Member HowtoForge Supporter

    I am new to this great software and the forum ;-)
    I am running an already configured server with another ISP. Now I want to change to ispconfig - but first want my customers to try it out.

    My idea: I installed vmware-server on the webserver an than I download the great out-of-the-box ISPConfig image from vmware-website.

    It is now running but I can't reach the control panel or any website (which are different from the already existing ones !) out of the internet.

    The server has a public ip and I setup the vmware-image to use NAT. On both now run an apache2 and postfix ....

    The server is reachable but the vmware-image not ;-(
    I tried to work with apache proxypass and .htaccess and apache mod_rewrite - but did't come to a result.

    Does anyone in this forum tried out an equal solution?
    Or does someone knows "out-of-the-box" ( ;-) what to do, that the websites and mails on the vmware-ISPconfig reach there target?

    Thank you a lot
  2. falko

    falko Super Moderator ISPConfig Developer

    Did you configure your server to forward requests to your virtual machine? Why didn't you use bridging?
  3. vistree

    vistree Member HowtoForge Supporter

    Hi Falco,
    thank you for reply.

    I want to install on a hosted webserver - and there is only one public IP included :mad:

    The Forwarding is exact the problem I can't fit. I tried to find rules for iptables to portforward incomming on port 81 to port 81 of the vm-guest. I think I have not the accect way how to implement.

    The same is on using apaches mod_rewrite.

    May knowledge is to small to get it work ....

    Any hints?

  4. falko

    falko Super Moderator ISPConfig Developer

    Have a look here:
  5. vistree

    vistree Member HowtoForge Supporter

    Hi Falca,
    thank you for replying again - and for the link.

    It is a mess, but it still does not work. I tried to forward port 81 to receive the IPSConfig control panel and to forward all request to port 80 (both to the virtual machine). There is a long request time in the webbrowser, but result is a connection error.

    I also tried the XEN 2.6 steps - but still no result. Also tried to disable all the rules on my host (iptables -F / iptables -t nat -F) and then inserting your rules - but still no result.

    The host-machine uses a physical network adapter eth0 with public IP, a NAT-adapter from vmware (vmnet8 - ip and lo. The vm has eth0 with and lo.

    Are there any rules in addition to your XEN tutorial to include in iptables?

    Thank you a lot
  6. vistree

    vistree Member HowtoForge Supporter

    I got it!!

    I found a first solution on my vmware-problems. I can now redirect tcp-request from a incomming port (e. g. 81) to the virtual machine.

    What I did not know is: vmware-server has a configuration file for NAT, where you can enable port-forwarding.

    Including 81:



    does the job without any additional changes (e.g. on iptables).

  7. freeborn

    freeborn New Member

    Using bridge network more easier but you need one more real IP for vmware.
    Last edited: Aug 16, 2011
  8. vistree

    vistree Member HowtoForge Supporter

    ISPconfig on vmware virtual machine solved

    He freeborn, as I mentioned out above - I have only ONE public IP so I need NAT.

    After several hours of "trial and error" I found the solution.
    1. I had to include 2 lines in vmware nat.conf

    Nothing else as portforwarding using iptables!

    Than - and this seems to be a bug within vmware-server - I had to start the vmware-image using a vmware console tool (vmware-cmd /pathtoimage/image.vmx start) instead of using the remote "VMWare Server Console".

    And: now it works ;-)

    Thank you for all the hints!

Share This Page