Problems configuring Z-Push

Discussion in 'Server Operation' started by bax, Mar 27, 2014.

  1. bax

    bax Member

    Hi there!

    I have several problems while I try to get Z-Push running properly and I hope someone can help me!

    I'm running a Debian Wheezy Server with ISPConfig3 and NGINX w/ PHP-FPM.

    I installed Z-Push 2.1.1 and try to get it running with an iPhone (iOS 7)

    1. the From-header and the Return-path-header of my sent emails show [email protected] instead of [email protected]

    2. Is there any possibility to have my full name in the From-field in the email-header?

    3. I have tomcat_solr for dovecot installed and running (tested w/ imap via telnet) but I can't use search on my iPhone – the log throws "Searchtype 'MAILBOX' is not supported."

    4. When I switched from syncing the last month of emails to "unlimited" on my iPhone, push broke and I had many "Mobile Loop" messages in my logs. Is there any parameter I could change?

    5. I already tried fmbiete's Z-Push fork on Github ( Search did work here but S/MIME did not (which I would like to keep). I wasn't able to figure out how to combine the two versions for my needs…

    Thank you already, I hope to find help!
  2. srijan

    srijan New Member HowtoForge Supporter

    Please follow the guide, it may help you.

  3. bax

    bax Member

    Hi Srijan,

    I followed the guide in it's main aspects, but I don't find where it would cover the problems I faced.
  4. bax

    bax Member

  5. misterm

    misterm Member

    Hello Bax
    about setting up the trash and sent to the folder you found the right configuration elements?
    imap.php on file


  6. bax

    bax Member

    Hi misterm,

    I didn't change anything on the folders, it just worked for me from the beginning!
  7. misterm

    misterm Member

    Hello and thanks for your help
    And you for sharing files?
    Is it possible to have a tutorial that explains the proper functioning of the instalaltion this version?
    For when I am doing this installation, the only thing that blocks it can not find the file logs


    In any case, thank you for your help


Share This Page