Problems make suphp-0.7.0 Centos 5.2 - ISPCONFIG Howto

Discussion in 'HOWTO-Related Questions' started by jaze, Apr 4, 2009.

  1. jaze

    jaze New Member

    Im trying to follow falko exellent howto - on installling ISPCONFIG 3 on Centos everyting has worked till now.

    Im at this point -
    cd /tmp
    tar xvfz suphp-0.7.0.tar.gz
    cd suphp-0.7.0/
    ./configure --prefix=/usr --sysconfdir=/etc --with-apr=/usr/bin/apr-1-config --with-apxs=/usr/sbin/apxs --with-apache-user=apache --with-setid-mode=owner --with-php=/usr/bin/php-cgi --with-logfile=/var/log/httpd/suphp_log --enable-SUPHP_USE_USERGROUP=yes
    make <---- here is where I receive the errors
    make install <---- here is where I receive the errors

    [...] similiar output.
    mod_suphp.c:24:19: error: httpd.h: Ingen sådan fil eller filkatalog
    mod_suphp.c:25:25: error: http_config.h: Ingen sådan fil eller filkatalog
    mod_suphp.c:26:26: error: http_request.h: Ingen sådan fil eller filkatalog
    mod_suphp.c:27:23: error: http_core.h: Ingen sådan fil eller filkatalog
    mod_suphp.c:28:27: error: http_protocol.h: Ingen sådan fil eller filkatalog
    mod_suphp.c:29:23: error: http_main.h: Ingen sådan fil eller filkatalog
    mod_suphp.c:30:22: error: http_log.h: Ingen sådan fil eller filkatalog
    mod_suphp.c:31:25: error: util_script.h: Ingen sådan fil eller filkatalog
    mod_suphp.c:47: fejl: expected â=â, â,â, â;â, âasmâ or â__attribute__â before âMODULE_VAR_EXPORTâ
    mod_suphp.c:59: fejl: expected specifier-qualifier-list before âtableâ

    and I get this when i try to restart apache

    Starting httpd: httpd: Syntax error on line 210 of /etc/httpd/conf/httpd.conf: Syntax error on line 1 of /etc/httpd/conf.d/suphp.conf: Cannot load /etc/httpd/modules/ into server: /etc/httpd/modules/ cannot open shared object file: No such file or directory

    Any ideas to get me moving ...
    Last edited: Apr 4, 2009
  2. jaze

    jaze New Member

    well found that
    yum install mod_suphp worked

    after i edited
    vi /etc/suphp.conf

    as Falko says in
    The Perfect Server - CentOS 5.2 [ISPConfig 3] - Page 5

    moving on, so lets see what else happens :D
  3. stottle

    stottle New Member

    I had the same problem and was also able to run yum install on suphp, but I ran into problems after that. The problems were blank webpages from testing webmail, phpmyadmin and the initial page for ISPConfig.

    This was on CentOS 5.3 x86_64. Turns out this error was because I only had the i386 install of apr-devel (I think configure was looking for an x86_64 header file that didn't exist from the i386 install). Running "yum install apr-devel" got the x86_64 version, and then I was able to successfully use ./configure, make and make install on suphp after that.

    Note, since I had already run yum install suphp, I had to delete the yum installed version of /etc/httpd/conf.d/suphp.conf and create a new one with only the line from the tutorial ("LoadModule suphp_modules modules/").

    BTW, the newest version of ISPConfig ( seems to work on CentOS 5.3 if you follow the CentOS 5.2 instructions. (and replace i386 with x86_64 if you use 64 bit).

    Hope this helps anyone else who runs into the same problem.

    Thanks for the great tutorials!
  4. kird03

    kird03 New Member

    Had same problem as topic starter...

    The post of stottle made the How-to working again!:)

  5. stevebor1

    stevebor1 New Member

    sorry to resurrect the dead, but i have wasted 2 days and longs on this.

    Had the same problem as stottle, php woulnd parse correctly after running the Perfect Server Centos ISPConfig. I was getting plank white pages for webmail and phpmyadmin.

    Solution, from above, edit suphp.conf, comment everything out except 'LoadModule suphp_modules modules/'
  6. agriz

    agriz New Member

    I am getting the same error.
    I tried

    yum install mod_suphp
    There is no package available.
    I know it is old thread.

    I m now using CentOS 6

    Which repo did you use to install mod_suphp ?

  7. falko

    falko Super Moderator ISPConfig Developer

    mod_suphp is available in the RPMforge repo, so you need to enable this first.
  8. agriz

    agriz New Member

    can i get the url to enable RPMforge repo?

  9. falko

    falko Super Moderator ISPConfig Developer

Share This Page