Problems with OwnCloud Installation

Discussion in 'HOWTO-Related Questions' started by hec1152, Nov 6, 2014.

  1. hec1152

    hec1152 New Member

    This is a continuation of thread I started inside another unrelated thread at

    I uninstalled and reinstalled the Windows client but I got the same message as before:

    Failed to connect to OwnCloud at http://spocku/owncloud/status.php - server replied: Service Unavailable​

    Back on the server side, I notice that when I try to login to Owncloud there via localhost/owncloud, I get message:

    Data directory (/mnt/virtual/@CLOUD/ocdata) is readable by other users
    Please change the permissions to 0770 so that the directory cannot be listed by other users.​

    I have changed permissions to the data directory in above message to 0770 and even to 777 but that made no difference.

    I did realize that I might have skipped a couple of steps in the instructions in the install davfs2 section 4. This is because when I try to mount owncloud/, after entering username and password, I get message:

    /sbin/mount.davfs: Mounting failed.
    503 Service Unavailable

    I did the rest of the steps in that section but i'm guessing my problem is the above message and the fact that owncloud/ didn't mount. At this point I'm wondering if it would be better if I started over and tried to follow instructions more closely? How would I do that if that's what you recommend? (e.g. how to completely remove owncloud stuff so that it would really be a startover?). Or if you think I could continue from here to find problems what should I do next?
  2. srijan

    srijan New Member HowtoForge Supporter

    This needed to be done for secondanry Ubuntu client, i.e. if you want to connect the owncloud server with any other Ubuntu desktop/server then it is needed to install davfs. When you are mending any Ubuntu owncloud server then davfs automatically installed by the owncloud -server package.

    There could be any firewall/ufw rule preventing the access of the owncloud server. Please make ensure if you use any firewall-server then it should allow the owncloud server.
  3. hec1152

    hec1152 New Member

    There's no firewall. I have it disabled.
  4. srijan

    srijan New Member HowtoForge Supporter

    Please check if any firewall rule prevailing on your source of internet, may be your Router policies.
  5. srijan

    srijan New Member HowtoForge Supporter

  6. hec1152

    hec1152 New Member

    My access to localhost/owncloud was not working anymore. Considering that I decided to start over with owncloud on server. I removed/purged owncloud and eliminated all traces of it on the server. This time I set up a user acct for owncloud named ocuser. I dedicated a storage location for it's data at /mnt/virtual/@CLOUD/owncloud/ocdata. And I added ocuser to the database for access to it. When I setup owncloud with the first browser login I designated ocuser as the user. I designated the above path as the location for the data. Now when I tried to access it I get:

    Data directory (/mnt/virtual/@CLOUD/owncloud/ocdata) is invalid
    Please check that the data directory contains a file ".ocdata" in its root.​

    I have done that by making sure there's an ocdata file in the above directory but that doesn't seem to help. What am I doing wrong?

    P.S. I'm doing this from account user hec which is the account under which apache2 is run (if that matters).
  7. hec1152

    hec1152 New Member

    I've been trying to study this problem and I think it as to do with the permissions and ownership of the owncloud folder path (i.e. in my case, /mnt/virtual/@CLOUD/owncloud/ocdata. For whatever reason, root is the owner of that. i.e.

    drwxrwxrwx 1 root root 256 Nov 8 17:35 .
    drwxrwxrwx 1 root root 0 Nov 8 13:06 ..
    -rwxrwxrwx 1 root root 0 Nov 8 13:06 .ocdata
    -rwxrwxrwx 1 root root 0 Nov 8 13:07 owncloud.log

    I fixed the .ocdata file problem by creating empty file so now I'm down to the message:

    Data directory (/mnt/datadrive/@CLOUD/owncloud/ocdata) is readable by other users
    Please change the permissions to 0770 so that the directory cannot be listed by other users.​

    I can't find a way to make that go away. Is my presumption that this has to do with permissions and ownership correct? If so, what should the ownership on the above folder look like? Should it be owned by the same user that owns the var/www path that apache2 serves up? And can I even get there since I'm using NTFS filesystems. (II'm reading up on ntfs-3g just in case, but I don't think I fundamentally understand what this should look like).
  8. hec1152

    hec1152 New Member

    Answering my own questions: I got it to work up to the point where I can log into the local server with localhost/owncloud. My data directory is on a NTFS drive that's accessed with filesystem ntfs-3g. type ntfs wouldn't work because it did not allow the correct permission/ownerships on the data directory. These turned out to be the id under which apache2 ran (and i't www folder). That was www-date. To get this I had to go into supervisor and do chown -R www-data:www-data /mnt/datadrive/@CLOUD/owncloud/ocdata to get ownership correct. Also had to mark these with 0770 permissions, all from supervisor.

    Now it works locally but still no go at access from windows client. I get the message "You are accessing the server from an untrusted domain......" when I try to access from browser. And when I try to access from client, I get "Error: Error downloading http://spocku/owncloud/ - server replied: Bad Request". I checked to verify that windows firewall was disabled. Not sure where to go from here. I appreciate any comments.
  9. srijan

    srijan New Member HowtoForge Supporter

    Clear your browser certificates, or try to access the site through another browser like firefox/chrome

Share This Page