Proftp no account created. ISPconfig start warnings

Discussion in 'Installation/Configuration' started by jackoob, Dec 17, 2008.

  1. jackoob

    jackoob New Member

    Hi all,

    after a long time :eek: with ISPconfig I need some help with two points.

    1. When I create FTP user (ISP Site->User & Email->new) with Administrator permission, the account is not created so I cann't log on ftp. While I have anonymous directives in proftpd.conf the anonymous ftp works well.

    I am using CentOS 5.2, my proftpd.conf:
    ServerName "ProFTPD Default Installation"
    ServerType standalone
    DefaultServer on
    Port 21
    UseIPv6 off
    Umask 027
    MaxInstances 30
    User nobody
    Group nobody
    DefaultRoot ~
    IdentLookups off
    ServerIdent on "FTP Server ready."
    AuthOrder mod_auth_file.c
    AuthUserFile /etc/proftpd.passwd
    AuthGroupFile /etc/
    RequireValidShell off
    PersistentPasswd off
    AuthPAMConfig off
    AllowOverwrite on
    <Limit SITE_CHMOD>
    Include /etc/proftpd_ispconfig.conf

    2. while restarting or starting ISPconfig, I get this warnings in messages:
    17.12.2008 - 10:55:41 => WARN - WARNING: could not open file

    17.12.2008 - 10:56:20 => WARN - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 728: WARNING: could not /home/admispconfig/ispconfig/web/multidoc/edit/bastille-firewall restart &> /dev/null

    I don't think this two hang together. The second one seems like bad symlink, but where is this configuret?

    Thanks for your answers...
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Looks as if your ispconfig is not installed properly. Did you install the ispconfig sql dump manually or was it installed by the ispconfig installer automatically?
  3. jackoob

    jackoob New Member

    It was installed by ispconfig installer. Does your answer appears for second point? The warnings started to be showen after I made changes in default configuration of E-mails (I added right location ov virtusertabs). But maybe there were more than this change.
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    What exactly did you change?
  5. jackoob

    jackoob New Member

    Server: Domain, IP address
    Web: Conf.dir, document root
    E-mail: virtuser file, sendmail cw, maildir switched on
    DNS: named.conf, Zonefile

    Quit a lot but I think that all of them had a bad value ...
  6. jackoob

    jackoob New Member

    ok, I tried to install ispconfig from the scratch and the warnings disappeard.

    But still it is impossible to create Proftpd user account.
  7. falko

    falko Super Moderator ISPConfig Developer

    Do you get any errors when you try to log in? What's in your logs?
  8. jackoob

    jackoob New Member

    Hi Falko,

    this is a piece of log where some warnings are showed.

    18.12.2008 - 01:21:36 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 281: Could not select database
    18.12.2008 - 01:23:47 => INFO - USER:
    web2_testuser:x:10002:10002:Jan Dovolil:/home/www/web2:/bin/false
    18.12.2008 - 01:23:47 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 664: cp -fr /root/ispconfig/isp/user_standard_index.html_en /home/www/web2/user/web2_testuser/web/index.html
    18.12.2008 - 01:23:47 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 720: setquota -u web2_testuser 256000 257024 0 0 -a &> /dev/null
    18.12.2008 - 01:23:47 => INFO - /root/ispconfig/scripts/lib/config.lib.php, Line 721: setquota -T -u web2_testuser 604800 604800 -a &> /dev/null
    18.12.2008 - 01:23:47 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_procmail.lib.php, Line 60: cp -f /root/ispconfig/isp/conf/forward.master /home/www/web2/.forward
    18.12.2008 - 01:23:47 => WARN - maildirmake /home/www/web2/user/web2_testuser/Maildir &> /dev/null, Line 110: WARNING: could not maildirmake /home/www/web2/user/web2_testuser/Maildir &> /dev/null
  9. FryShadow

    FryShadow New Member

    looks like we have same problem too :(

    I try to restart the proftpd but luckily there's no error appear BUT.. I can't login through ftp :( maybe the user is not created
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    Is the user listed in /etc/passwd?
  11. radim_h

    radim_h Member HowtoForge Supporter

    i have same problem on Debian Etch after update from 2.2.26 to 2.2.29

    strange thing is that it always giving message
    WARN - maildirmake /var/www/web1/user/domain.tld_user/Maildir &> /dev/null, Line 110: WARNING: could not maildirmake /var/www/web1/user/domain.tld_user/Maildir &> /dev/null

    domain.tld_user is always right in the message but there is always web1..

    As Jsckoob is metioning /home/www/web2/user/web2_testuser errro mesasge maybe complaining always about first existing account on the server

    I'm using [DOMAIN]_ mode

    EDIT !!!
    after some discovering i found that this error message was there always, (Tried on two different servers)
    but until 2.2.28 always with correct web number.
    Since 2.2.29 there is only web1 and ISPConfig is writing all new accoutns files for any domain into web1 folder !!!

    user is located in /etc/passwd

    i ha'd to recompile 2.2.28 again and now the problem with /web1 is also there, i'm not sure what is it depending on, but it's real pain in the ass
    Last edited: Dec 19, 2008
  12. falko

    falko Super Moderator ISPConfig Developer

    Please make a backup of /etc/passwd, /etc/shadow and /etc/group and run
  13. radim_h

    radim_h Member HowtoForge Supporter


    you saved me from heart attack! :))
  14. jackoob

    jackoob New Member

    Great! Thank you very much too!!!

Share This Page