Proftpd howto and Etch

Discussion in 'Server Operation' started by Jamesk5, Apr 16, 2007.

  1. Jamesk5

    Jamesk5 New Member

    Hey guys,
    I've just tried the ProFTPd tutorial ( on Etch Stable and can't seem to get it to work.
    I had it working on Etch (unstable) previously, and have the same DB tables as the last install.

    One thing I had to do is download the .deb file for libmysqlclient12-dev (and it's required packages) and install them using dpkg because they weren't avaliable for etch.

    Has anyone tried using the tutorial on Etch and been able to get it working? The logs for proftpd just show connections just being disconnected (no problems with authentication or anything like that).

    Thanks guys,
  2. falko

    falko Super Moderator ISPConfig Developer

    I think you should use libmysqlclient15-dev on Etch.
    Any errors in your log files?
  3. Jamesk5

    Jamesk5 New Member

    updating to libmysqlclient15-dev didn't seem to fix the problem? Should I need to restart any services other than proftpd??

    Log follows:
    Apr 17 23:53:57 rainbow proftpd[28420] ([]): FTP session closed.
    Apr 17 23:53:57 rainbow proftpd[28421] ([]): FTP session closed.
    That was for the login attempt after getting libmysql... and restarting postfix.
  4. falko

    falko Super Moderator ISPConfig Developer

    I'm not sure what the problem is on your system, but I'll try to write the same tutorial for Etch soon. :)
  5. rodti

    rodti Member

    Yikes. I'm having the same after a dist-upgrade to Etch. The ProFTPd/MySQL connection is completely hosed.

    Removing and reinstalling the proftpd and proftpd-mysql packages (DB tables still in place), disabling IPv6 and adding the SQL lines to proftpd.conf, then restarting proftpd doesn't seem to work.

    ProFTPd shows in /var/log/proftpd/proftpd.log as started. No errors. There were no errors at the command prompt when it started. When I try to log in I get:

    421 Service not available, remote server has closed connection.

    Something is _very_ broken with Etch and this how-to :(
  6. falko

    falko Super Moderator ISPConfig Developer

    I don't think anything is broken. The tutorial is for Sarge and is working on Sarge, and Etch is different from Sarge. That's all.
  7. rodti

    rodti Member

    OK, to rephrase, it works fine with Sarge but upgrading to Etch breaks what had been done with the how-to. An Etch how-to or an amendment to the how-to showing how to fix it would be great, as I now can't access my server with FTP! :D
  8. rodti

    rodti Member

    Sorted - comment out the following line in /etc/proftpd/modules.conf

    LoadModule mod_sql_postgres.c
    Restart ProFTPd and it seems to work fine! :)
  9. falko

    falko Super Moderator ISPConfig Developer

    As I said above, I'll try to write one soon. :)
  10. rodti

    rodti Member

    The solution is almost in a comment on page 2 of the how-to. Someone had suggested uncommenting the Postgre line, but in fact it needs to be commented out. Perhaps just poor English! I tried to add another comment to the how-to to that effect but it doesn't work in Safari.
  11. falko

    falko Super Moderator ISPConfig Developer

    You can't comment with Safari? Do you get any error messages?
  12. rodti

    rodti Member

    A couple of warnings about the commenting system being in beta, but no specific error messages!
  13. falko

    falko Super Moderator ISPConfig Developer

    Can you post the exact warnings?
  14. rodti

    rodti Member

    When I hit 'Reply' I get the message:

    Safari support is very limited and should be considered experimental.
    So there is no need to even submit bugreports on this early version.
    If I type in a message and press Preview it then moves to the next screen but loses the message. I get the following error at the top:

    [COLOR="Red"]The body of your comment is empty.[/COLOR]
    I tried typing in a message and pressing Post Message, but I get the same error:

    [COLOR="Red"]The body of your comment is empty.[/COLOR]
  15. falko

    falko Super Moderator ISPConfig Developer

    That's strange. I'll try and see if I can find anything related to this in the sources of the comment module.
  16. Jamesk5

    Jamesk5 New Member

    Incidently, I got my problem with my ProFTPD fixed, thanks for the help! :)
  17. amurray

    amurray New Member

    I too was getting the following error:

    421 Service not available, remote server has closed connection

    While I was going through the ProFTPd / Debian Etch tutorial. I came here to find the solution, everything that was suggested in the posts that I read I had already looked into. However the mod_postgres?!?! something gave me an idea. I changed my password for the ProFTPd user in both the MySQL database and the proftpd.conf file and everything started working fine.

    The problem (I am guessing) is that ProFTPd doesn't like passwords that contain symbols (such as ^, #, *, etc.) The password that I was using contained a ^ symbol. Once I put in a password that only contained letters and numbers the problem seemed to go away.

    I am not entirely sure that is what fixed the problem, but I offer it out there in case someone else is having the same problem, that just might be the fix.


Share This Page