Protected Folder Issue - ISPCONFIG

Discussion in 'Installation/Configuration' started by Angel245, Dec 5, 2013.

  1. Angel245

    Angel245 New Member

    Sorry if this post is in the wrong place. I am using ISPCONFIG for my control panel (Ubuntu 12.04 - NGINX). It works perfectly except for one item. I have several websites installed and while they were under development, I instituted the PROTECTED FOLDER/USER option to prevent the public from accessing my sites. Now that the sites are ready to go public, I have removed the Protected Folders and Users from the system, however, when attempting to access the websites via the world wide web, a user and password is still being asked for even though I deleted the protected folder and user from the ISPCONFIG 3 system and ISPCONFIG 3 DATABASE and also made sure the .htpasswd file from my website's script was removed. I cannot access the site even though the protected folder and user have been deleted. How can I fix this please?
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    You edited data in the ispconfig database manually? Thats a really bad idea as this will break your system. Manua changes in the ispconfig database are no valid configuration transactions, so the system will ignore them in best case and will stop writn changes to disk in the worst case.

    Pleases ee debug instructions here if yo want to check if your changes in the database broke the system:

    nginx neither uses nor supports .htaccess files. Nginx has all its configuration in the nginx site config files.
  3. Angel245

    Angel245 New Member

    I removed the password protected folders from the ISPCONFIG admin panel - not manually in the database. I checked the database to make sure they were indeed removed via the deletion process in the ADMIN panel and they were. Additionally I ran the debug sequence and no errors displayed.
    Last edited: Dec 6, 2013
  4. Angel245

    Angel245 New Member

    I cannot access the site now due to ISP still calling for a password and username even thought the protected folder/user has been deleted; I get 401 Authorization Required message. I went back into the ISP ADMIN panel and re-instituted the protected folder/user for the website and I can now access the site. It appears I can only access the site if a protected folder/user is installed. Why is this happening? I wish to remove this option as the site is ready to go public.
  5. Croydon

    Croydon ISPConfig Developer ISPConfig Developer

    Have you checked the nginx vhost file for the web?
    Is there still a http auth check?
    Is there a vhost file with .err extension?
  6. Angel245

    Angel245 New Member

    The auth check was present and I commented it out. Works now. Thank you very much!!! :)
    Last edited: Dec 7, 2013
  7. Angel245

    Angel245 New Member

    Hello I have another issue related to ISPCONFIG - I received this reoccurring error message in the ISPC Cron Log:

    FATAL: Could not load /lib/modules/3.8.13-xxxx-grs-ipv6-64/modules.dep: No such file or directory

    Failed to load mptctl

    3 Error: (CLI:003) Specified controller does not exist.

  8. spikes

    spikes Member

    I am struggling with the same issue. How do I check

    Is there still a http auth check?

    Please help, very urgent.


    I want to have the protected folder but it asks me for user and passw but after input usr and passw can still not access. There is a url rewrite in place. I have put both folders as protected folders but still no access to web pages. So because I cannot get access I removed everything but now still no access. Not sure what's going on. I went and check folders and manually deleted .htaccess. Still no access.
    Last edited: Mar 28, 2014

Share This Page