Question in "Virtual Users And Domains With Postfix, Courier And MySQL (Fedora 8)"

Discussion in 'HOWTO-Related Questions' started by davy_wei, Feb 23, 2008.

  1. davy_wei

    davy_wei New Member

    I followed all the steps in the "Virtual Users And Domains With Postfix, Courier And MySQL (Fedora 8)" and finished the setup. The link of this HowTo is

    After I finished the setup, I tried "telnet localhost 110", and entered user and pass. I got the error

    [[email protected] ~]# telnet localhost 110
    Connected to localhost.
    Escape character is '^]'.
    +OK Hello there.
    user [email protected]
    +OK Password required.
    pass test123
    -ERR Maildir invalid (no 'cur' directory)
    Connection closed by foreign host.

    I check the /home/vmail folder. There is no domain over there. I read the HowTo again, but there are no steps to create domain folder, and Maildir, cur, tmp folders in the vmail folder.

    Does anyone knows how to force Postfix to create the folder if they are not existing? I used to use qmail and vpopmail. It creates the domain and Maildir folders when you creating the user accounts. However, this HowTo only tells me to create accounts in MySQL directly using phpMyAdmin.

    Please help.

    Thank you.
  2. davy_wei

    davy_wei New Member

    OK, I added maildir folders by maildirmake. Now pop3 is working. However, I still can't send out emails. I tried in telnet directly, it looks fine, but I didn't get any emails in the destination mail box.

    I also tried sending/receiving email in MS-Outlook, but smtp kept asking me password! Any ideas?
  3. davy_wei

    davy_wei New Member

    Here is the error message I got in Outlook

    Your message did not reach some or all of the intended recipients.

    Subject: test
    Sent: 2/23/2008 2:40 PM

    The following recipient(s) cannot be reached:

    '[email protected]' on 2/23/2008 2:40 PM
    554 5.7.1 <[email protected]>: Relay access denied

    Then I picked SMTP server need authentication. When sending email, outlook kept asking me the password.
    Last edited: Feb 23, 2008
  4. davy_wei

    davy_wei New Member

    The smtp is working properly, but why the email is not sent and received? Please help!!!:( :( :( :(

    [[email protected] var]# telnet localhost 25
    Connected to localhost.
    Escape character is '^]'.
    220 ESMTP Postfix
    250-SIZE 10240000
    250 DSN
    mail from:<[email protected]>
    250 2.1.0 Ok
    rcpt to:<[email protected]>
    250 2.1.5 Ok
    354 End data with <CR><LF>.<CR><LF>
    test from remote host
    test #2
    250 2.0.0 Ok: queued as 6D7E38901BF
    221 2.0.0 Bye
  5. falko

    falko Super Moderator ISPConfig Developer

    The Maildir is created automatically once you send the first email to this account.
  6. davy_wei

    davy_wei New Member

    Thank you for your replying.

    Do you mean I don't need to worry about anything if I follow the steps of setup and everything is supposed to work properly. But why can't I receive any emails?
    Last edited: Feb 24, 2008
  7. falko

    falko Super Moderator ISPConfig Developer

    Any errors in your mail log?
    Please make sure that the MX records of your domains point to the correct server. You can check it like this:
    dig mx
  8. davy_wei

    davy_wei New Member

    Hi, Falko,

    Thanks for your kindly reply. I checked the MX records and it shows correctly.

    ; <<>> DiG 9.5.0b1 <<>> mx
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 8450
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

    ; IN MX

    ;; ANSWER SECTION: 600 IN MX 10

    ;; Query time: 230 msec
    ;; SERVER:
    ;; WHEN: Mon Feb 25 22:56:18 2008
    ;; MSG SIZE rcvd: 50

    Now I can receive the emails and they are delivered correctly. However, I still can't send out emails. The emails were sent out without return, but they are not delivered. I tried it both in telnet and MS-Outlook. I don't know where they are right now, but it looks like something is wrong. How should I do right now? What should I check?

  9. davy_wei

    davy_wei New Member

    Here is actual problem for me.

    I can only send emails to the same domain emails. For example, I can send emails from [email protected] to [email protected]. I did it successfully in MS Outlook. However, I can't send the email to my email I checked "My outgoing server (SMTP) requires authentication" in Outlook. When I click "Send" button, outlook kept asking my password for sending.

    Do you know why this happens? What should I check and how to solve the issue.

    I appreciate it.
  10. falko

    falko Super Moderator ISPConfig Developer

  11. mspIggy

    mspIggy New Member

    hi - i am having the same problem

    mx records are fine...

    i am guessing it is POP Authenticated Relaying somewhere that has not been turned on

    did you ever fix your problem? if so please tell me how


    thank you

  12. falko

    falko Super Moderator ISPConfig Developer

    Which problem exactly?

Share This Page