Questions about older versions of Outlook support connections

Discussion in 'General' started by Dy-2024, Mar 27, 2024.

  1. Dy-2024

    Dy-2024 New Member

    Hello everyone.

    I've been using ISPConfig for over a month now and I've learned a lot from HOWTOFORGE and I've solved some problems.

    At the moment, I still have some open questions, such as:
    Outlook 2010, I can't use POP3 (port 995) to encrypt the connection.
    Outlook prompts "The specified server has been found, but the server is not responding.Please check if the port and SSL information are correct".
    Also, SMTP,port 465, works fine.

    I realized that maybe my Outlook version was too old.
    Because I tested with Thunderbird and Iphone and Webmail everything worked fine.

    I hope to find a way to work even in old Outlook.

    Thank you.
     
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    You will likely have to adjust these lines in your /etc/dovecot/dovecot.conf file to allow older TLS versions and maybe SSLv2 or SSLv3

    Code:
    ssl_protocols = !SSLv2 !SSLv3 !TLSv1 !TLSv1.1
    ssl_min_protocol = TLSv1.2
    ssl_cipher_list = ECDHE-ECDSA-AES128-GCM-SHA256:ECDHE-RSA-AES128-GCM-SHA256:ECDHE-ECDSA-AES256-GCM-SHA384:ECDHE-RSA-AES256-GCM-SHA384:ECDHE-ECDSA-CHACHA20-POLY1305:ECDHE-RSA-CHACHA20-POLY1305:DHE-RSA-AES128-GCM-SHA256:DHE-RSA-AES256-GCM-SHA384
     
  3. pyte

    pyte Well-Known Member HowtoForge Supporter

    Allthough possible you really should upgrade your Outlook version. You can find Office 2019 license keys for relativly cheap from trusted vendors online.
     
  4. Dy-2024

    Dy-2024 New Member

    Thank you.
    I'll try it right away.
     
  5. Dy-2024

    Dy-2024 New Member

    Thank you.
    I've been working on it.Even though there may be hundreds of thousands of people in this area (probably more) still using version 2010.
     
  6. Dy-2024

    Dy-2024 New Member

    Hello.
    I tried the following:
    /etc/dovecot/dovecot.conf

    ssl_min_protocol = TLSv1
    or
    ssl_min_protocol = TLSv1.1
    or
    ssl_min_protocol = TLSv2
    or
    ssl_min_protocol = TLSv3

    Outlook still doesn't work properly prompts server doesn't support the specified connection encryption type.

    Also, after completing the attempt from above, I tried the following again:
    /etc/dovecot/conf.d/10-ssl.conf

    ssl_min_protocol = TLSv1
    or
    ssl_min_protocol = TLSv1.1
    or
    ssl_min_protocol = TLSv2
    or
    ssl_min_protocol = TLSv3

    Outlook still prompts the same error and does not work properly.
    Thank you.
     
  7. Dy-2024

    Dy-2024 New Member

  8. pyte

    pyte Well-Known Member HowtoForge Supporter

    Please check the configuration settings of dovecot and check the mail log for the auth attempts. Run "doveconf –n | grep ssl" to check the current ssl settings. May activate "auth_verbose = yes" in dovecot and check the logs for your login, it will tell you what login mechanism outlook uses and why it fails.
     
  9. Dy-2024

    Dy-2024 New Member

    Thank you.
    I'll try it right away.
     
  10. Dy-2024

    Dy-2024 New Member

    Run "doveconf –n |grep SSL"
    Here are the results:
    Code:
    doveconf: Warning: NOTE: You can get a new clean config file with: doveconf -Pn > dovecot-new.conf
    doveconf: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:14: ssl_protocols has been replaced by ssl_min_protocol
    doveconf: Error: Could not find a minimum ssl_min_protocol setting from ssl_protocols = !SSLv2 !SSLv3 !TLSv1 !TLSv1.1: Unrecognized protocol 'SSLv2'
    doveconf: Warning: NOTE: You can get a new clean config file with: doveconf -Pn > dovecot-new.conf
    doveconf: Warning: Obsolete setting in /etc/dovecot/dovecot.conf:14: ssl_protocols has been replaced by ssl_min_protocol
    doveconf: Error: Could not find a minimum ssl_min_protocol setting from ssl_protocols = !SSLv2 !SSLv3 !TLSv1 !TLSv1.1: Unrecognized protocol 'SSLv2'
    dovecot.conf
    The current configuration is as follows:
    Code:
    protocol pop3 {
      pop3_uidl_format = %08Xu%08Xv
      mail_plugins = $mail_plugins quota
      auth_verbose = yes
    Log?
    /var/log/mail.log
    As follows:
    Code:
    Mar 28 16:02:17 (My server hostname) dovecot: pop3-login: Disconnected (no auth attempts in 0 secs): user=<>, rip=(My ip), lip=(My server ip), TLS: Connection closed, session=<q+wk8bMU7cjaFPsc>
    Or I run "doveadm log errors"
    As follows:
    Code:
    Mar 28 16:01:49 Warning: auth: auth client 0 disconnected with 1 pending requests: Connection reset by peer
    Mar 28 16:02:38 Warning: auth: auth client 0 disconnected with 1 pending requests: Connection reset by peer
    Thank you.
     
  11. pyte

    pyte Well-Known Member HowtoForge Supporter

    Fix your Dovecot errors, the message itself advises you what to do. You may want to refer to the official documentation which is quiet good.
    After fixing these errors try again and if it still not works check which AUTH mechanism Outlook uses and see if your dovecot server provides the method
     
  12. Dy-2024

    Dy-2024 New Member

    I do love to fix the Dovecot error but I really don't know how to fix it, even though the message itself might suggest what to do but I still don't understand.

    I've also tried to refer to the official documentation countless times and fixed some issues, but I still don't know how to fix the current problem.

    I have also tried to check the AUTH mechanism used by Outlook but the problem is not solved, maybe my technique or method is limited.
    I'll try to check again now and submit a report later.

    Thank you for your help.
     
  13. pyte

    pyte Well-Known Member HowtoForge Supporter

    The documentation for reference: https://doc.dovecot.org/settings/core/#core_setting-ssl_cipher_list

    Remove the line "ssl_protocols" in your configuration and instead replace it with "ssl_min_protocol". If you want to disable TLS1.0 for example you would set "ssl_min_protocol=TLSv1.1" as this is the minimum TLS version then required to talk to your dovecot server. This should get rid of the warning and the error.

    You can see all options here: https://doc.dovecot.org/settings/core/#core_setting-ssl_min_protocol
     
  14. Dy-2024

    Dy-2024 New Member

    Thank you.
    I'll try it right away.
     
  15. Dy-2024

    Dy-2024 New Member

    I've spent days trying repeatedly and still not working.
    In response to this problem, give up for now.Because I have some more urgent issues to deal with.

    Thank you very much "till" and "pyte" for their help.
     
    Last edited: Apr 3, 2024
  16. fanto666

    fanto666 Member

    What is your setting for ssl encryption? Pop3 should have port 995 with encryption "ssl/tls", it looks like you use "starttls" instead.
     

Share This Page