quota and ispcfg related question

Discussion in 'Installation/Configuration' started by Ovidiu, Mar 9, 2006.

  1. Ovidiu

    Ovidiu Active Member

    hi guys,

    I am just curious as to how "good" ispcfg works with quota.
    as an example I have a site with a quota of 5000MB, when I go into ispcfg => sites => thissite => STATISTICS I see:
    below this I see:

    Storage Space: 5000MB
    used: 11011.74k
    DB::MySQL 11011.7k

    I never had ispcfg showing me more correct data, I thought its just not working...
    But quota is implemented right because I got an email about this site exceeding its quota just several minutes ago, saying.

    Group: web2
    Used Storage Space: 5081.53 MB
    Allocated Storage Space: 5000.00 MB

    so quota is indeed working. I wanted to see where these 5GBs are located so I tried:

    h5810:/var/www# du -s -c -h web2/
    3,9G web2/
    3,9G insgesamt

    so where would the rest of 5081 GB be ? how can I locate that?
    I set their logsize to 10% in ispcfg and now watch this:

    h5810:/var/www/web2# du -s -c -h log/
    768M log/
    768M insgesamt

    how can that be? 768 >>> 500 (=10% of 5000)

    I really hope somebody can help clarify these..
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    I guess you have not configured ISPConfig to use the du command with sudo:


    Otherwise the admispconfig user is not able to get the correct size of the website directory. You can verify this by logging in as root, run du for a special website directory, then run "su admispconfig" t switch to the ispconfig user and run the same du command.

    I also recommend to have a look at your /tmp directory and /home/admispconfig/ispconfig/temp directory if there are any files from this user or group.
  3. Ovidiu

    Ovidiu Active Member

    I followed the advice given in that link, still I did not find anything from this group (web2) inside /tmp nor inside /home/admispconfig/ispconfig/temp ...

    is there a command to find everything belonging to a certain group?
  4. goldstift

    goldstift New Member

    Hi Tenaka,

    you can find all files belonging to a group with
    > find / -group web2

    I used this for exactly the same problem.

  5. Ovidiu

    Ovidiu Active Member

    thx :) although this is a year old post, your info is still useful and welcome.
  6. goldstift

    goldstift New Member

    Hi there,

    for your interest:
    In Fedora Core 6 there is by default a special setting in the sudo config file. This switch has to be changed if you want to use sudo in php scripts.

    type "visudo" and search for
        Defaults requiretty
    I commented this out (with a #) and everything worked fine.

    Apparenly Fedora Core 6 is the only OS that has the setting and it's very hard to find/ guess good search terms to find any info about this switch. That's why i'd like to add some more key words here for others experiencing the same problem:
    - $go_info["server"]["sudo_du_enabled"] = true;
    - /root/ispconfig/httpd/logs/error_log
    - sudo: sorry, you must have a tty to run sudo
    - FC6 Fedora 6
    Last edited: Jan 18, 2008

Share This Page