Quota exceeded when creating container

Discussion in 'Installation/Configuration' started by eager, Feb 4, 2009.

  1. eager

    eager New Member

    Quota exceeded on CentOS 5.2 when creating OpenVZ container

    I've installed CentOS 5.2 on a VirtualBox x86_64 VM and applied the latest OpenVZ patch (028stab059.6). When I run the following command

    vzctl create 201 --ostemplate centos-5-x86_64-minimal --config vps.basic

    I get a series of disk quota and tar unpack errors starting with this:

    tar: ./fastboot: Cannot open: Disk quota exceeded

    I have confirmed that disk quotas on the CentOS VM system are turned off. There is plenty of available disk space in /vz, as well as /. I am able to untar the template into /vz/private without problem.

    Any suggestions?
    Last edited: Feb 4, 2009
  2. falko

    falko Super Moderator ISPConfig Developer

    My guess is that the uncompressed template is already bigger than the disk space that is configured in /etc/vz/conf/201.conf.
  3. eager

    eager New Member

    Thanks for the reply.

    There isn't any 201.conf. There is ve-vps.basic-conf-sample, which contains the line "DISKSPACE="1048576:1153024".

    I copied ve-vps.basic-conf-sample to 201.conf and increased both values tenfold. Running the vzctl create w/o --config vps.basic gives the same error.

    Why would config for a VPS container have anything to do with the error being issued from tar?
  4. falko

    falko Super Moderator ISPConfig Developer

    Hm, not sure what's happening. Is SELinux disabled?
  5. eager

    eager New Member

    SELinux is disabled.

    I ran strace, but there's nothing obvious.

Share This Page