Quota on NFS mount (ISPconfig)

Discussion in 'Installation/Configuration' started by Shinichi, Feb 20, 2019.

  1. Shinichi

    Shinichi New Member

    Hello there.

    Because this is my first post here, I want to thank all you guys for your great contributions. Keep it up! But let’s go on to the problem now:

    I set up a webserver following this HOWTO:

    Divergent from this setup I want to mount the /var/www directory via NFS (due to virtualization and backup considerations). To do so, I installed the nfs-common package via apt and appended the second line to the /etc/fstab file:

    UUID=... / ext4 errors=remount-ro,usrjquota=quota.user,grpjquota=quota.group,jqfmt=vfsv0 0 1 /var/www nfs vers=3,timeo=14,rsize=16384,wsize=16384,nolock,intr 0 0​

    On executing mount –av the output "/var/www: successfully mounted" was printed on the screen and everything works as expected so far.

    After that I created a test site and set the hard disk quota to 128 MB. By taking a look at „Website quota (Harddisk)“ on the Sites tab from the ISPconfig Control Panel there are the following values for the test site:

    Used space: NAN
    Soft limit: unlimited
    Hard limit: unlimited​

    Please note: To check if there is a problem with the installation in general I restored a snapshot and tested everything without using an NFS mount. There were no problems and the quota values were displayed correctly by ISPconfig, so the problem apparently is caused by using an NFS share.

    To solve the problem I did a lot of web research and found many posts having similar problems but there were no real solutions for it. So finally I decided to post this issue here.

    Additional information:

    To check if there is any error message from quota I turned quotas off via quotaoff -avugm and did a quotacheck -avug with the following output:

    Skipping [/var/www]​

    There were no error messages or something like this.

    To understand the behavior of quota I did some web research again and figured out, that quota should use rpc.rquotad on the remote machine to include the NFS share quotas. So i checked if rpc.rquotad is running on the remote machine via rpcinfo -s and got the following output:

    program: 100011
    versions(s): 2,1
    netid(s): tcp,udp
    service: rquotad
    owner: superuser​

    However I’m curious about the fact, that quota is simply skipping the mount point despite of the fact, that -a option on quotacheck should scan all filesystems.

    Do you have any ideas how to make quotas work for the NFS share or how to make quotacheck at least to try to scan?
    Last edited: Feb 20, 2019

Share This Page