quotas on ocfs2

Discussion in 'Installation/Configuration' started by nhybgtvfr, Jan 16, 2015.

  1. nhybgtvfr

    nhybgtvfr Well-Known Member HowtoForge Supporter

    I'm following the instructions for a 'perfect server' setup, but I'm having problems with the quotas.

    the webserver has a drive /dev/sda, with an ocfs2 partition /dev/sda1, mounted at /var/www
    I've installed quota and quotatool. and added (according to the debian instructions)
    to the mount listing in /etc/fstab.
    but I can't remount the folder, mount.ocfs2 unrecognised mount option 'usrjquota.aquota.user' or missing value.
    same with usrjquota=quota.user,grpjquota=quota.group,jqfmt=vfsv0 from the Ubuntu instructions.
    at first, I thought it was just quota's not being enabled on the filesystem, so I ran tunefs.ocfs --fs-features=usrquota,grpquota
    but i get the same mounting errors, I can get it to mount if I just use usrquota,grpquota in fstab

    but then when I run quotacheck -avugm I get:
    quotacheck: skipping /dev/sda1 [/var/www]
    quotacheck: cannot find filesystem to check or filesystem not mounted with quota option

    quotaon -avug returns:
    /dev/sda1 [/var/www]: group quotas turned on
    /dev/sda1 [/var/www]: user quotas turned on

    running the quotacheck again, still skips /dev/sda1, and says' it can't file a filesystem to check.

    so are quotas actually working now?, if not , what do I need to do?

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Check e.g. with:

    repquota -avug

    if it shows the correct quotas after you created a website in ISPConfig which has a harddisk limit.
  3. florian030

    florian030 Well-Known Member HowtoForge Supporter

    AFAIK you should use usrquota and grpquota (without the j) on an ocfs2-volume. You don´t need quotacheck as quota is a part of fsck.ocfs2.

    Did you add the quota-support with mkfs.ocfs2?
  4. nhybgtvfr

    nhybgtvfr Well-Known Member HowtoForge Supporter

    florian030, nope, not when I first created the partition, I hadn't seen anything about it at that time. fortunately it's not in production yet, I shut down all but one node, unmounted it on there, and ran tune.ocfs2 --fs-features=usrquota,grpquota /dev/sda1, according to the docs, that should add quota support to the existing partition.

    till, thanks for that, won't be able to try it till later today, I suspect it's all ok anyway, quotaon reports user and group quota's as being on on that partition. just the quotacheck response threw me a bit.
  5. nhybgtvfr

    nhybgtvfr Well-Known Member HowtoForge Supporter

    repquota works great thanks.
    since mounting the partition and checking the quota's with ocfs2 is different from the instructions from the 'perfect server' examples, I'm just wondering is there anything else that needs to be changed anywhere, or is that it? everything's good to go and ispconfig will pick up quota breaches as expected?
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    The quota is enforced by the linux quota system adn filesystem, not by ispconfig. ISPConfig is just setting the limits by running the linux quota commands. So if you want to know if quota works, login as a user that has quota enabled for its website and try to store a file that exceeds your quota.

Share This Page