recovering from backup, issues

Discussion in 'Installation/Configuration' started by mashton, Jan 10, 2012.

  1. mashton

    mashton New Member

    I had a server crash, but had backups.

    I've built a new ispconfig2 server ( since that was what old machine was ) and needed to get up and running fast.

    So far installed centos, and completed the perfect server install for ispconfig2.

    I then imported all the databases ( except, mysql & information schema) , updated the data in the db_ispconfig to point to new IP, and updated DNS servers to point to new IP.

    I have also, populated the /var/www tree with a complete backup of the other servers /var/www tree.

    I have some issues. One inbound email appears to not be being delivered to the email accounts but there is nothing in the postfix mail queue. The other is none of the websites are loading, and I am just getting the default ispconfig home page.

    Any ideas ?

  2. mashton

    mashton New Member


    Just an update.

    I've added forwards to a few of the email accounts to the users gmail accounts and they are getting their forwarded email there, but still no delivery.

    Now in the postfix log, have this error:
    postfix/trivial-rewrite[6784]: fatal: file /etc/postfix/ parameter default_privs: unknown user name value: nobody

    but if I run:
    /usr/bin/id nobody
    uid=99(nobody) gid=99(nobody) groups=99(nobody)

    so nobody exists.

    Also getting this error:
    postfix/master[18330]: warning: process /usr/libexec/postfix/trivial-rewrite pid 6784 exit status 1
    postfix/master[18330]: warning: /usr/libexec/postfix/trivial-rewrite: bad command startup -- throttling

    No idea on the websites not working. Vhosts_ispconfig.conf seems to be properly configured and all sites point to the right directory:
    DocumentRoot /var/www/web138/web
    and the directories are owned by the account admin.

    Any pointers would be appreciated.

  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Vae you migrated all website users and groups from the /etc/passwd, /etc/shadow, /etc/gshadow and /etc/group files from the old server to the new server?
  4. mashton

    mashton New Member

    Yes I copied group, passwd, gshadow & shadow.

    I also copied Vhosts_ispconfig.conf , but edited the IP address to the new machines IP.

    Also copied proftpd.conf, and in postfix I copied virtusertable & local-host-names.

    When users that have had their passwords reset logged in they got their old emails from the recovery, but no new emails. I can see them in the maillog coming in, and being forwarded to gmail for the few that have that set up, but nothing is getting delivered.

    I used as my basis, and a few other threads here to do the copy/move.

    I also altered /home/admispconfig/ispconfig/tools/clamav/bin/clamassassin to use clamdscan instead of clamscan due to load ( we receive about 100,000 emails a day ).
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Did you copy only the relevant lines of the ispconfig users and groups or the whole files? Copying the whole files can mess up the systm as the users and groups of the daemons and users like nobody can have different ID's on the old and new server.
  6. mashton

    mashton New Member

    I straight copied.

    ugh so do I have to figure out the underlying ID's to correct?
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    If you have a backup of the original files of the new server, I would restore them. And then copy only the lines for ispconfig mailbox users and ispconfig groups to the files on the new system. I guess you should be able to regognize them with their prefix if you use one on your server.
  8. mashton

    mashton New Member

    Unfortunately I don't have them, stupid me did not create .bak files like I usually do.

    Now I have run /usr/sbin/pwck & /usr/sbin/grpck to repair the files, then restarted ispconfig but still no joy.
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    I fearthat these commands repair only the syntax of the files, they can not detect if a userid is correct for a given service.

    Did you follow one of the perfect setup guides or a similar tutorial that can be redone so that you are able to replicate the exact same base setup? Then it might be an option to redo the setup in a vm (e.g. vmware or virtualbox) by doing the installation steps in the exact same order, this should result in passwd and group files with the same IDs which you might use for your current setup as basis.
  10. mashton

    mashton New Member

    That's a thought. But Falko jumped on the server and it turned out that due the machine being behind a firewall and it having external and internal IP's .

    Once he altered conf for internal IP everything has started working.


Share This Page