Remote Framework update beta 3.1- sql and lng files fixed

Discussion in 'Developers' Forum' started by grandpagenocide, Apr 7, 2008.

  1. grandpagenocide

    grandpagenocide ISPConfig Developer ISPConfig Developer

    thats very odd because i just installed it myself again as a test, did you unzip the file first and use browse to upload the pkg file, or are you trying to install it as a zip?
  2. bernholdt

    bernholdt Member

    Well i got it to work by deleting the tmp files and redownload. think i got a couple of bad downloads today
  3. rvarkevisser

    rvarkevisser New Member

    Updating Reseller limits

    Is it possible to update a current reseller limit? I want to add additional websites to a current reseller, without having to set the limits to -1. I want to add up, for instance, the diskspaces and add that to the reseller diskspace limit.
  4. grandpagenocide

    grandpagenocide ISPConfig Developer ISPConfig Developer

    please see page 2 of this post and download the example scripts and look at test.php in the package, it has a reseller update in it
  5. grandpagenocide

    grandpagenocide ISPConfig Developer ISPConfig Developer

  6. falko

    falko Super Moderator ISPConfig Developer

    I get a 404 when I try to download that file.
  7. grandpagenocide

    grandpagenocide ISPConfig Developer ISPConfig Developer

  8. lubos

    lubos New Member

    How to use it?

    I downloaded script and went trough the installation. Uploaded test with uncommented parts of script and all what I get when I go to website is

    Script end ...

    What I am missing? How to use this script?
    (I remember that I bought it before from rhwebhosting and I never used it because the same problem)
    Thanks for your help
  9. falko

    falko Super Moderator ISPConfig Developer

    Did you check out the examples in the test.php file?
  10. lubos

    lubos New Member

    Yes I uncommented one at the time and saved with different names. Afterwards I called that new file in browser and nothing happened except the message mentioned before.

    Script end ...

    You can see for example here
    Last edited: Apr 9, 2009
  11. falko

    falko Super Moderator ISPConfig Developer

    Can you post the file here?
  12. grandpagenocide

    grandpagenocide ISPConfig Developer ISPConfig Developer

    2 questions
    1. did you successfully install the remote framework?
    2. did you install libxml2?
  13. Bikkies

    Bikkies New Member

    pkg file seems to be missing

    On this page I found the link for remote framework
    Even though the extension is .pkg, when I download it comes as a .zip file.
    I unzip it but there is still no .pkg file.
    Tried uploading the .ins file but only get same error as bernholdt earlier.
    "Installation instructions not found: /home/admispconfig/ispconfig/temp/a50e1e4f787ccff99668e4ea89828fe7/package.ins"

    Any idea what is wrong here because I am lost?
    Thx in advance.
    Last edited: Apr 22, 2009
  14. till

    till Super Moderator Staff Member ISPConfig Developer

    This is a .pkg file, take a look at the file extension and do not unzip it.
  15. Bikkies

    Bikkies New Member

    Thanks Till, but using WinXP & clicking on the link results in -

  16. t-mug

    t-mug New Member


    Rename the ".zip" extension of the downloaded file back to ".pkg" and with that renamed package use the package manager of ISPConfig.
  17. lubos

    lubos New Member

    Remote script not working

    Sorry, I did not check here for a while. I will check now regularly until it will be resolved. Thank you upfront for your help.

    I successfuly installed remote framework
    I have libxml2 installed on server and I have curl on PHP

    I changed server in autosign.php and in auto.php (I am not sure if there should be both files or just one of them, I put on the web in the folder where is AddWebsite file both of them and soap.lib as well.)

    Bellow is file for adding website, only part for adding website is uncommented.
    I changed username and password to my settings plus a) changed IP for server where is ISPconfig installed and b) changed server to use URL instead of IP - none version worked.

    You can find resulted screen with error here: AddWebsite
    Thanks upfront for your help

    One Q - do I have to insert some code to create tables or something?

    Info about file: I tried to upload here full length but it won't let me. so I deleted here all other entries which are in my file on server but are commented out with

    * ISPConfig Soap Connector
    * Version 1.3
    * (c) Projektfarm GmbH 2005
    * This script requires PHP with CURL extension
    // Insert here your 42go Server
    $server_url = "https://mine.IP.inser.ted:81";
    // creating object for soap_client
    $soap_client = new soap_client($server_url.'/remote/index.php');
    // Username and Password of the remoting user (not identical
    // with the user to log into the web interface!)
    $parameters = array('user' => 'my-user-name-for-remote',
                        'pass' =>  'remote-user-password');
    // Login into 42go Server
    $session_id = $soap_client->call('login',$parameters);
    // Error Check
    if($err = $soap_client->getError()) die("Error: ".$err);
    //*other parts are here
    // Adding a Web
    $params = array (         'sid'        => $session_id,
                                            'module'         => 'web',
                                            'function'         => 'web_add',
                                            'params'        => array (         kunde_title => 'Kunde6', // reseller_title or reseller_group
                                    web_title => '',
                                    web_host => 'www',
                                    web_domain => '',
                                    web_ip => '',
                                    web_speicher => '100', // MB
                                    web_dns => 0,
                                    web_userlimit => 5,
                                    web_domainlimit => 2,
                                    web_shell => 0,
                                    web_cgi => 1,
                                    web_standard_cgi => 1,
                                    web_php => 1,
                                    web_php_safe_mode => 1,
                          web_ruby    => 1,
                          web_python    => 1,
                                    web_ssi => 1,
                                    web_ftp => 1,
                                    web_frontpage => 0,
                                    web_mysql => 1,
                                    web_mysql_anzahl_dbs => 5,
                                    web_ssl => 0,
                                    web_anonftp => 0,
                                    web_anonftplimit => 0,
                                    web_wap => 1,
                          web_cron    => 1,
                                    web_individual_error_pages => 1
    $web_id = $soap_client->call('service',$params);
    if($err = $soap_client->getError()) die("Error: ".$err);
    echo $web_id;
    //* again other parts are here
    // 42go Server logout
    $soap_client->call('logout',array('sid' => $session_id));
    // Error Check
    if($err = $soap_client->getError()) die("Error: ".$err);
    echo "<br>Script end ...";
    One more Q: I have server on and script on can that be a problem? Does the script require to be on the same domain as the server is? If yes, server has, can the script be on or it has to be on

    Update: I tried the file on and got an error:

    Error: CURL Extension, or OpenSSL extension w/ PHP version >= 4.3 is required for HTTPS
    But: when I do
    apt-get install curl libcurl3 php5-curl 
    (I don't know exact command so I tried all what i found on the web :eek:
    I get response that they are already newest version.
    Last edited: Apr 23, 2009
  18. afandino

    afandino ISPConfig Developer ISPConfig Developer

    Need help uderstanding remote frame work


    I have installed the latest stable of ispconfig i believe 2.32
    The latest remote frame work

    I seem to be having the same issue as lubos in that that the script completes without error yet nothing is updated in the data base. The session table has no entries.

    It seems that the soap client never makes a good connection. I have place indicators in the function service in yet the service function never gets executed. I am running text.php and routine add reseller.

    I also am having trouble turning on advanced debug information for the soap connection.

    Why do i get this behavior ?

  19. t-mug

    t-mug New Member

    Remoting tables lost after update

    After updating stable core to 2.2.32 both of the remoting tables were missing completely. While the users got lost this way, no SOAP connection worked after this.
    Whitout the tables (remote_user and remote_session), strange enough, no error occurs, if you try adding a new remoting user in the tools section of the control panel. It simply does not work and shows an empty user list after "adding". So I did some db research and finally readded the db struct of both tables to db_ispconfig manually. Adding users is now possible again and SOAP connections are working as well.

    Anyone else here with the same experience?

    EDIT: If I don't misunderstand the miraculous database "update" routine of the install.php file, then this is by design. So this should be a bug. Really nobody else noticed that?
    Last edited: May 30, 2009
  20. bahadircolak

    bahadircolak New Member

    How can I install remote api to ISPConfig 3?

    I've downloaded the pkg file and libxml2, installed libxml2 but don't know where to put .pkg file?

Share This Page