Remoting API - data_processing_error after update

Discussion in 'Installation/Configuration' started by ZaKlaus, Sep 20, 2014.

  1. ZaKlaus

    ZaKlaus New Member

    I updated my ISPConfig instance to today and my script for adding site stopped working.

    I can register new ISPConfig account via remoting API normally without errors, but when it comes to adding a website it shows data_processing_error from $client->_getLastResponse() function.

    Here is my code, which was working before the update:

    $_SESSION['uid'] is client_id.

    As I said, in it was working normally, now I have this problem. I've been looking for that error in, but I don't really understand where is the real problem.

    I've also configured permissions in security_settings.ini like this:

    I hope things will get sorted out.

    EDIT: Please, tell me if you need additional information about my server or some logs.

    Last edited: Sep 21, 2014
  2. ZaKlaus

    ZaKlaus New Member

    Well, I've hoped somebody will figure it out.

    I'll investigate it further, but I've tried everything already, even the sample code.

    EDIT: I've found the solution on existing thread ( So my problems are solved now. Thanks for the great software.

    Last edited: Sep 28, 2014
  3. bmi64

    bmi64 New Member

    I have the same "data_processing_error" from $client->_getLastResponse() function, could you tell me what was your error please ?

Share This Page