Request: Perfect Ubuntu 6.06 LTS - Automatic LAMP Server Installation (co-location)

Discussion in 'Suggest HOWTO' started by Anim, Jun 1, 2006.

  1. Anim

    Anim New Member

    Hi all

    I've been reading the Perfect ISP Server install for Ubuntu Badger 5.10 and found them to be amazing articles. So a massive thanks to this website and the authors that did those articles.

    The latest version of Ubuntu (v6.06) got released today so I put my request here for anybody willing to update the perfect server how-to's to this version with the posibility of using the Automatic LAMP installation option as a starting point (or not if more control can be done from manually installing these packages).

  2. falko

    falko Super Moderator Howtoforge Staff

    Of course we will write a "Perfect Setup" for Ubuntu 6.06, but you need to give us some time. You can't expect us to publish that tutorial the same day.
  3. Anim

    Anim New Member

    Hiya Falco

    Haha, I didnt expect the tutorial to be updated the same day as release. But its nice to hear that you have it in the pipeline.

  4. sjau

    sjau Local Meanie Moderator

    Of course I can :p ... the only question is whether my expectations do matter to you :D
    Anyway, how many days have already passed? :rolleyes:
  5. falko

    falko Super Moderator Howtoforge Staff

    For the impatient: I've just installed Ubuntu 6.06 Server, and ISPConfig installs fine on it. You can follow the Ubuntu 5.10 tutorial ( ), there aren't many changes (just install PHP5 instead of PHP4, that's it). :)
  6. sjau

    sjau Local Meanie Moderator

    Is PHP5 necessary? I still refuse to use it ^^
  7. Anim

    Anim New Member

    Morning all,

    I tried that initially but had a few problems using 64bit server, then did the Fudora Core 5 - 64Bit instead which worked a treat but I noticed the reboot time of Fedora is twice as slow as Ubuntu for some reason.

    I will give it another go today (I have only been using Linux for 2 days) and make notes this time.

    I did have one issue with ISPConfig that I couldn't work out. I want the root IP to be listed as a website via ISPConfig so that I can manage it but it (i think) doesn't allow this.

    If I added the single IP as a new website in ISPConfig then on another windows station setting the hosts to

    and typing in in a browser would result in a sharedIP warning when I tried to connect to it. I know that the domain is simply reversing to its IP (via windows hosts) and sending that and the ISPConfig settings needs the domain to identify the Virtual server. I kind of know the problem but not how to make it work like I want. Is there a way to say that the first website isn't a virtual website and it exclusivly uses the only available IP address?

    I have a Linux machine (will be co-located when its setup) and my windows development machine. I want to setup my initial website on the root IP and be able to manage that via ISPConfig. When its all up and running I will then take it to a datacenter (at which point I will get 10 IP addresses) and if I want can host other websites on it using ISPConfig to set them up.

    Is that possible?

    Also, Is it just a case of changing the IP addresses in ISPConfig to match that what I am assigned when it goes to the datacenter and all will be ok? or is there more to it?

    Is there a way to start Gnome on Ubuntu Server? I couldn't figure it out from the CLI.

  8. falko

    falko Super Moderator Howtoforge Staff

    No, you can also use PHP4.
  9. falko

    falko Super Moderator Howtoforge Staff

    I think you use the wrong IP address in ISPConfig. What's in Vhosts_ispconfig.conf?

    Have a look here to learn howe to change the IP adress:
  10. Anim

    Anim New Member

    Guess I'm impatient :) I tried again today with quite a few issues....

    Page 3: Edit /etc/apt/sources.list And Update Your Linux Installation

    The changes here are I guess to comment out the CD-ROM source at the top of the file and uncomment the Universe sources at the bottom. The contents are different to that of Badger tho so dont change them. Packages are now sourced via your internet connection rather than from the CD-ROM.

    On the same page it goes on to say

    Install SSH Daemon
    apt-get install ssh openssh-server

    After this has been done you can then use Putty to login to the server and do the rest of the tutorial from the workstation with the browser on. (Copy and Paste heaven)

    Additional documentation for SSH setup can be found here

    It shows how to change the default SSH port to some other port which (as far as i can see) improves security slightly.

    Moving down page 3 the line that says

    [FONT=Verdana, Arial, Helvetica, sans-serif]Install/Remove Some Software[/FONT]
    [FONT=Verdana, Arial, Helvetica, sans-serif]Now let's install some software we need later on and remove some packages that we do not need:[/FONT]
    [FONT=Courier New, Courier, mono]apt-get install binutils cpp cpp-4.0 fetchmail flex gcc gcc-4.0 libarchive-zip-perl libc6-dev libcompress-zlib-perl libdb4.3-dev libpcre3 libpopt-dev linux-kernel-headers lynx m4 make ncftp nmap openssl perl perl-modules unzip zip zlib1g-dev autoconf automake1.9 libtool bison autotools-dev [/FONT][FONT=Verdana, Arial, Helvetica, sans-serif](in 1 Line!!)[/FONT]

    Fails because it can't find ncftp, I checked that universe was enabled in my sources list and it is so got stumped here. As we install ftpprod anyway I just omitted this from the above line and 14.9MB of download later i could carry on.

    Also, was there meant to be a bit that we remove somewhere as the title suggests?

    When running quotacheck I get several warnings:

    Warning Quotafile var/quota.user was probably truncated, cant save quota settings

    Warning Quotafile var/ was probably truncated, cant save quota settings


    .....continuing to the end of page 3 completed without issue.

    Page 4

    [FONT=Verdana, Arial, Helvetica, sans-serif]MySQL[/FONT]
    [FONT=Verdana, Arial, Helvetica, sans-serif][FONT=Courier New, Courier, mono]apt-get install mysql-server mysql-client libmysqlclient12-dev[/FONT][/FONT]

    [FONT=Verdana, Arial, Helvetica, sans-serif][FONT=Courier New, Courier, mono]This had a warning that the package libmysqlclient12-dev has no installation candidate. As I installed the LAMP installation I will assume that I have most of SQL already installed and continued on without fear of a half assed system :D[/FONT][/FONT]

    A few steps down the command...

    [FONT=Courier New, Courier, mono] mysqladmin -h -u root password yourrootsqlpassword[/FONT]

    [FONT=Verdana, Arial, Helvetica, sans-serif][FONT=Courier New, Courier, mono]Caused a "lost connection to MySQL Server during Query" error. I had entered the correct domain name and password but still got this error. I checked the netstat -tap table and all was as it shoud be so searched the forums and found other people had this error but the advice was to contiune and set the password later.

    [FONT=Verdana, Arial, Helvetica, sans-serif][FONT=Courier New, Courier, mono]I gave up at this point. I want to find out why MySQL isnt working correctly, maybe the LAMP install sets a password up already?

    [FONT=Verdana, Arial, Helvetica, sans-serif][FONT=Courier New, Courier, mono]Right, off to install again and go through just the Server install without LAMP and see if I get past this point.[/FONT][/FONT]

    [FONT=Verdana, Arial, Helvetica, sans-serif][FONT=Courier New, Courier, mono]The problem for me is that im doing most of the instructions without any knowledge of why but with each install attempt i'm starting to figure out the why. Intresting stuff really.[/FONT][/FONT]

    [FONT=Verdana, Arial, Helvetica, sans-serif][FONT=Courier New, Courier, mono]One area that I think is causing me some issues is the hosts file.[/FONT][/FONT]

    [FONT=Verdana, Arial, Helvetica, sans-serif][FONT=Courier New, Courier, mono]I need to read up on that. In windows its just IP <domain> but here we are using things like localhost.localdomain localhost server1[/FONT][/FONT]

    [FONT=Verdana, Arial, Helvetica, sans-serif][FONT=Courier New, Courier, mono]and I dont understand what the instructions....
    [FONT=Courier New, Courier, mono]echo > /etc/hostname [/FONT]
    [FONT=Courier New, Courier, mono]/bin/hostname -F /etc/hostname[/FONT] for

    more reading....

    [FONT=Verdana, Arial, Helvetica, sans-serif][FONT=Courier New, Courier, mono]
    [FONT=Verdana, Arial, Helvetica, sans-serif][FONT=Courier New, Courier, mono]Anim

    PS. Thanks for your previous reply. I will look into that.
    Last edited: Jun 3, 2006
  11. falko

    falko Super Moderator Howtoforge Staff

    Right. My sources.list looks like this (I stripped out the comments):

    deb dapper main restricted
    deb-src dapper main restricted
    deb dapper-updates main restricted
    deb-src dapper-updates main restricted
    deb dapper universe
    deb-src dapper universe
    deb dapper-security main restricted
    deb-src dapper-security main restricted
    deb dapper-security universe
    deb-src dapper-security universe

    ncftp works for me.

    No, this is a little bit misleading. :)

    That's the normal behaviour when you set up quota for the first time. Nothing to worry about.

    This one worked for me, too. But I didn't use Ubuntu's LAMP installation. But you'll need the MySQL-devel package otherwise you won't be able to install ISPConfig.

    This means that MySQL is listening only on localhost, and then it is ok. If you want MySQL to listen on all interfaces, comment out

    bind-address           =
    in /etc/mysql/my.cnf and restart MySQL. Then
    mysqladmin -h -u root  password yourrootsqlpassword
    should work.
  12. Anim

    Anim New Member

    Quick update

    The penny dropped on my 5th install

    When going through the Ubuntu install I had been changing the hostname to something other than server1 so thats why all references to server1 failed. I just set hostname and forgot about it (smacks head in shame) and I also partitioned my drives slightly differently so /var wasnt working quite as expected.

    Edit: Thanks for the reply Falco, without all your help I would be days if not weeks behind on this (for me) high learning curve, jump in the deep end lets build a web server using an OS i've never used before plan :D

    Last edited: Jun 3, 2006
  13. Anim

    Anim New Member

    Im stuck at this bit :eek:

    So what does the instruction

    apt-get install autoconf automake1.4 autotools-dev libapache2-mod-php4 libkrb53 php4 php4-common php4-dev php4-imagick php4-mcrypt php4-rrdtool php4-sqlite php4-curl php4-domxml php4-gd php4-imap php4-ldap php4-mcal php4-mhash php4-mysql php4-odbc php4-pear php4-xslt


    Ive tried renaming all 4's to 5's which didn't quite work.

    Sorry to pester. I have got this far and now possibly need to start again as I have a broken mix of php4 and php5 on my system now :confused:

  14. falko

    falko Super Moderator Howtoforge Staff

    apt-get install autoconf automake1.4 autotools-dev libapache2-mod-php5 php5 php5-common php5-curl php5-dev php5-gd php-pear php5-ldap php5-mhash php5-mysql php5-mysqli php5-snmp php5-sqlite php5-xmlrpc php5-xsl php5-imap php5-mcrypt php5-pspell
    I've just finished the "Perfect Setup" for Ubuntu 6.06. I will publish it on HowtoForge in the next few days. :)
  15. Anim

    Anim New Member


    Really look forward to seeing it.
  16. falko

    falko Super Moderator Howtoforge Staff

  17. Anim

    Anim New Member

    Thanks Falco. Your guides are superb.
  18. falko

    falko Super Moderator Howtoforge Staff

  19. Anim

    Anim New Member

    A strange site that digg site. Well, i gave you a digg and posted my comments. Much of the other comments there were my own thoughts initially but as I did it manually (not LAMP) I learnt so much more which to me is very valuable knowledge for troubleshooting.

    Now....back to messing with FTP lol
  20. falko

    falko Super Moderator Howtoforge Staff

    Thanks! :)
    I read the comments, you can ignore most of them as the guys there don't seem to have a clue what they're talking about. The best thing is: everybody says I should have tried the LAMP installation, but Ubuntu's LAMP installation seems to be buggy:
    So: real experts there on digg... :rolleyes:

Share This Page