[Resolved] Roundcube (webmail) unavailable after upgrade Debian 10 to 11

Discussion in 'Installation/Configuration' started by 30uke, Jul 21, 2023.

  1. 30uke

    30uke Active Member

    Hello,
    This has been resolved. Click here for the solution.
    First of all: thank you for all the great community support I did get over the past years. I am running my server thanks to ISPConfig and the community since the 1st of January 2019. I started with Debian Stretch and did update to Buster after a while. I did find the courage for the upgrade from Buster to Bullseye today.

    I did follow the excellent documentation found here:

    I have a few questions for which I will start separate threads.

    The problem I am facing at the moment is not urgent. I would like to solve the problem within a week. The problem is that webmail (Roundcube) doesn't work anymore after the upgrade.

    Querying https://s1.gigabitjes.nl/webmail results in a 404 error (not found).

    I did find the config folder which lists the following:
    Code:
    root@s1:/etc/roundcube# ls -lahs
    total 120K
    4.0K drwxr-xr-x   3 root root     4.0K Jan  9  2022 .
     12K drwxr-xr-x 135 root root      12K Jul 21 22:24 ..
    8.0K -rw-r-----   1 root root     4.1K Mar 16  2020 _20200316_config.inc.php
    4.0K -rw-r--r--   1 root root     1.3K Jan  4  2019 apache.conf
    8.0K -rw-r-----   1 root www-data 4.9K Mar 16  2020 config.inc.php
    4.0K -rw-r-----   1 root www-data 3.8K Jul 26  2019 config.inc.php.ucf-dist
    4.0K -rw-r-----   1 root www-data  524 Jan  4  2019 debian-db.php
    4.0K -rw-r--r--   1 root root      373 Nov 24  2018 debian-db-roundcube.php
     52K -rw-r--r--   1 root root      52K Jun  9  2020 defaults.inc.php
    4.0K -rw-r--r--   1 root root     3.1K Nov  5  2018 htaccess
    4.0K -rw-r--r--   1 root root      491 Nov 24  2018 lighttpd.conf
    4.0K -rw-r--r--   1 root root     2.8K Nov 27  2016 mimetypes.php
    4.0K -rw-r-----   1 root root     3.8K Jul 22  2019 _org_config.inc.php
    4.0K drwxr-xr-x  22 root root     4.0K Feb  9  2020 plugins
    
    I did also notice that Roundcube seems to be disabled by the maintainer of the package (?):
    Code:
    root@s1:/# find -name roundcube -print
    ./var/log/roundcube
    ./var/lib/roundcube
    ./var/lib/mysql/roundcube
    ./var/lib/apache2/conf/disabled_by_maint/roundcube
    ./usr/share/roundcube
    ./usr/share/roundcube/vendor/roundcube
    ./root/.composer/cache/repo/github.com/roundcube
    ./etc/roundcube
    The file "roundcube" in the folder "/var/lib/apache2/conf/disabled_by_maint" is empty.

    My question is what the best way is to fix Roundcube?
    I can't remember when and how I did install Roundcube in the past. I have memory problems after a period of illness (I am doing well - I just can't remember well). I think I might have to follow the following tutorial - although it's for Debian 10: https://www.howtoforge.com/perfect-...g-3-1/#-installnbsproundcube-webmail-optional

    Suggestions for the best way to resolve this are greatly appreciated. Thanks.
     
    Last edited: Jul 22, 2023
  2. ahrasis

    ahrasis Well-Known Member HowtoForge Supporter

    Try following the ISPConfig PST for Debian 10 manual setup steps (as there is none for Debian 11 except using automatic installer) to uninstall and reinstall your RC.
     
    30uke likes this.
  3. 30uke

    30uke Active Member

  4. 30uke

    30uke Active Member

    This is resolved.

    Roughly it boils down to the following:
    1. Remove and next create the roundcube database
      Code:
      mysql -u root -p
      DROP DATABASE roundcube;
      CREATE DATABASE roundcube;
      quit;
    2. Remove roundcube
      Code:
      apt remove roundcube* --purge
    3. Install and configure Roundcube (again)
      - per the tutorial - but without issuing the the command which creates the database (as it's already done)
      - enter a password (twice) when asked
    4. when you are adding the aliases to "/etc/apache2/conf-enabled/roundcube.conf" then also change the following:
      Code:
      <Directory /var/lib/roundcube/>
      This should not include the part "public_html/" (otherwise it will not work with the given aliases).
    Don't forget to set your identity and signature and so on.
     
    Th0m, till and ahrasis like this.

Share This Page