[resolved] See phpMyadmin code

Discussion in 'Installation/Configuration' started by Oitsuki, Dec 3, 2020.

  1. Oitsuki

    Oitsuki Member

    I reinstalled my OS on Ubuntu, the website works fine under php 7.4 but when I want to go on phpMyAdmin, In see the code :

    IPv6 : activated (necessary ?)
    Enable service monitoring and restart on failure : activated
    http 2 : activated

    No idea why I see that ?
    Thank you


    the result :
    /* vim: set expandtab sw=4 ts=4 sts=4: */
     * Main loader script
     * @package PhpMyAdmin
    use PhpMyAdmin\Charsets;
    use PhpMyAdmin\Config;
    use PhpMyAdmin\Core;
    use PhpMyAdmin\Display\GitRevision;
    use PhpMyAdmin\LanguageManager;
    use PhpMyAdmin\Message;
    use PhpMyAdmin\RecentFavoriteTable;
    use PhpMyAdmin\Relation;
    use PhpMyAdmin\Response;
    use PhpMyAdmin\Sanitize;
    use PhpMyAdmin\Server\Select;
    use PhpMyAdmin\ThemeManager;
    use PhpMyAdmin\Url;
    use PhpMyAdmin\Util;
    use PhpMyAdmin\UserPreferences;
     * Gets some core libraries and displays a top message if required
    require_once 'libraries/common.inc.php';
     * pass variables to child pages
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Does PHPMyadmin work if you leave out the :8080 from the URL?
  3. Oitsuki

    Oitsuki Member

    No it do not work.

    I have this message
    Your connection is not private
    Malicious individuals may be trying to steal your personal information from the ns320556.ip-94-23-7.eu site (such as passwords, messages or credit card numbers). Learn more
  4. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Adding a certificate helps, then that message from browser goes away. If you add a certificate the browser trusts, like Let's Encrypt.
    I guess you are not running ISPConfig? If that is the case, instructions on https://letsencrypt.org/ should work.
    But that probably does not affect PHPMyadmin.
  5. Oitsuki

    Oitsuki Member

    all my site are under https, no problem with the browser
    You can test this website for example : https://www.figures-shop.com
    Yes I running under IspConfig. My problem is only phpmyadmin
  6. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    With ISPConfig, create website with the FQDN of your server, and turn on LE in that website settings, then you get certificate and browsers stop complaining.
    The PHPMyadmin problem: when you go to that .../phpmyadmin url, browser shows that PHP code? Or something else? When PHP code is shown, it means web server for some reason does not know it should run that code instead of sending it to browser. The phpmyadmin installation is somehow faulty, needs troubleshooting.
  7. Oitsuki

    Oitsuki Member

    If I make a reconfigure on phpmyadmin, do you it can solve the problem ?

    If I remember I do that before, maybe it s a consequence :
    [email protected]:/home/ubuntu# a2dismod php7.4
    Module php7.4 disabled.
    To activate the new configuration, you need to run:
      systemctl restart apache2
    [email protected]:/home/ubuntu# a2dismod mpm_prefork
    Module mpm_prefork disabled.
    To activate the new configuration, you need to run:
      systemctl restart apache2
    [email protected]:/home/ubuntu# a2enmod mpm_event
    Considering conflict mpm_worker for mpm_event:
    Considering conflict mpm_prefork for mpm_event:
    Enabling module mpm_event.
    To activate the new configuration, you need to run:
      systemctl restart apache2
    [email protected]:/home/ubuntu# systemctl restart apache2
    Invalid unit name "apache2" escaped as "apache2\xe2\x80\x8b" (maybe you should use systemd-escape?).
    Failed to restart apache2\xe2\x80\x8b.service: Unit apache2\xe2\x80\x8b.service not found.
    [email protected]:/home/ubuntu# /etc/init.d/apache2 restart
    Restarting apache2 (via systemctl): apache2.service.
  8. Oitsuki

    Oitsuki Member

    I tried this not work :
    sudo dpkg-reconfigure phpmyadmin
    debconf: unable to initialize frontend: Dialog
    debconf: (Dialog frontend requires a screen at least 13 lines tall and 31 columns wide.)
    debconf: falling back to frontend: Readline
    Determining localhost credentials from /etc/mysql/debian.cnf: succeeded.
    Configuring phpmyadmin
    Since you are reconfiguring phpmyadmin, you may also want to reinstall the
    database which it uses.
    If you wish to reinstall the database for phpmyadmin, you should select this
    option. If you do not wish to do so (if you are reconfiguring the package for
    unrelated reasons), you should not select this option.
    Warning: if you opt to reinstall the database and install it under a name that
    already exists, the old database will be dropped without further questions. In
    that case a backup of the original database is made in /var/tmp/.
    Warning: if you change the name of the database, the old database will not be
    removed. If you change the name of the user that connects to the database, the
    privileges of the original user will not be revoked.
    Reinstall database for phpmyadmin? [yes/no] no
    Please choose the web server that should be automatically configured to run phpMyAdmin.
      1. apache2  2. lighttpd  3. none of the above
    (Enter the items or ranges you want to select, separated by spaces.)
    Web server to reconfigure automatically: 1
    dbconfig-common: writing config to /etc/dbconfig-common/phpmyadmin.conf
    dbconfig-common: flushing administrative password
    apache2_invoke phpmyadmin: already enabled
  9. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    You need to enable php-fpm (a2enconf php7.4-fpm) and restart apache.
  10. Oitsuki

    Oitsuki Member

    Perfect it works now. Thank you

Share This Page