round cube sopa error and invalid server name

Discussion in 'Plugins/Modules/Addons' started by chief, Sep 26, 2013.

  1. chief

    chief Member


    My problem:

    I have roundcube install and it works fine, but when accessing the settings-account i got a "soap error".
    Followed "" and got it sorted, via adding s to to make it

    while logged in i can change password and alter settingsa i could not otherwise change..

    but upon logout, i tried logging back in and got "Invalid server name". Change name back to
    And it refuses to log back in on any email address

  2. Horfic

    Horfic Member

    do you use the autoselect plugin?
    if you are using it, you probably didnt set it up correctly.

    is your ispconfig admin panel accessible per https or http
  3. chief

    chief Member

    Cheers for reply Horfic

    I use https to access ispconfig and https to access roundcube


    When you said
    i installed it via plugins from ispconfig interface and have not touched it

    cheers dave
  4. Horfic

    Horfic Member

  5. zapp

    zapp New Member

    Also do you use mod_security or mod_evaisive?
  6. chief

    chief Member

    ok, been away for weekend.
    I have upgraded to newest version from 0.8.5 to 0.9.4, overwrote /bin/ /program/ /plugins/ and /skins/ i dont have /SQL/

    and the i have same problem. when changing apps/ispconfig3_account/config/ from http: to https: i cannot login and get
    when as http: i can login, but users cannot change password and get

    I have followed readme.
    Step 6.
    this is mine
    I also changed line 1 to this
    So it just read this
    I also notice that in my plugins directory i have 37 plugins there, but in /config/ only 10 are there.
    This is a list of all in my plugins directory
    Hope this helps. ooh. im using ispconfig, roundcube version 0.9.4

    cheers dave
    Last edited: Sep 30, 2013
  7. Horfic

    Horfic Member

    so that you understand.

    everything that is in the $rcmail_config['plugins'] are active plugins.

    So if you want to disable a plugin, you just remove it from the list.
    A list of all available plugins is the directory plugins.

    So you first have to use https in the ispconfig_account config.

    And disable the autoselect plugin, as you didn't set it up correctly. Then people can login.
  8. chief

    chief Member

    thanks for reply horfic.

    If i understand what you said..

    $rcmail_config['plugins'] (all plugins listed here are active, i remove the plugins i want to disable.

    this is autoselect plugins:

    $rcmail_config['plugins'] = array();

    and i dont want it, so i add //$rcmail_config['plugins'] = array();
    to disable it and it should work

  9. chief

    chief Member

    i have made the changes and still the login page states "invalid server name"
  10. chief

    chief Member


    if /plugins/ispconfig_account/
    contains id_limit, use, password and soap_url.
    My server has 25 domains and soap_url is set to the hostname of the server.
    I have tried both IP address and hostname both using https://

  11. mangoldwen

    mangoldwen New Member

    Re: RoundCube

    Have you removed the plugin from the list?
    also if you have problems on how to remove or install plugins try to use roundcube manager


Share This Page