Roundcube and client denied by server configuration

Discussion in 'Installation/Configuration' started by lnxgs, Sep 3, 2023.

  1. lnxgs

    lnxgs Member

    Hello, I have Debian 12 and Ispconfig.
    I followed this guide to setup the server some weeks ago.
    I got aware that Roundcube does not work anymore. At the beginning it did.

    The error is:
    [authz_core:error] [pid 3805250:tid 139701042271936] [client x.x.x.253:46980] AH01630: client denied by server configuration: /var/lib/roundcube/

    In /var/lib/roundcube/ I have a .htaccess but no deny rules. I also remove (purge) all roundcube packages and reinstalled them but I got the same result.

  2. till

    till Super Moderator Staff Member ISPConfig Developer

  3. lnxgs

    lnxgs Member

  4. till

    till Super Moderator Staff Member ISPConfig Developer

    The link in ISPConfig GUI points to port 8081 as well in any recent ISPConfig version, so you do not have to type that in when accessing webmail from within ISPConfig. The problem with not using port 8081 is that it will fail when you secure a site with a jail, that#s why it is not used anymore.

    But back to your problem: Do you remember what you changed to cause this? You probably altered some global apache or nginx files.
  5. lnxgs

    lnxgs Member

    I installed updates (apt update && apt upgrade). I'll try to reboot and check apache configuration files.
  6. lnxgs

    lnxgs Member

    Fixed adding this code on /etc/apache2/sites-available/ispconfig.conf file (below phpmyadmin configuration):

    <Directory /var/lib/roundcube>
    Require all granted

    Not sure if it is safe.
  7. SamTzu

    SamTzu Active Member

    Ran in to same problem after trying to upgrade from Debian 11->12 with thom's tutorial.
    Roundcube stops working and I can't seem to fix it.
    I even purged it completely and reinstalled. Did not help.

    You don't have permission to access this resource.
    BTW. I think you meant port 8080.
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    No, the port to access RoundCube is port 8081 and not 8080. 8080 is ISPconfig, on this port you reach ISPConfig only. Port 8081 is the so called apps vhost, this is made to access other apps like phpMyAdmin and RoundCube.
  9. lnxgs

    lnxgs Member

    It sound me weird.
    I mean, I always use port 8080 in every installation I did. I installed at least 8-9 ispconfig panel over the years on Debian or Ubuntu (in the past also with Nginx, now only with Apache) and I'm use to go to to reach roundcube. And it was fine.
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    You could access RoundCube on most Apache servers on port 8080 due to a global Alias for RoundCube in Apache, but it was never configured specifically for this and you should not use port 8080 to access other software as this will make it run as ispconfig user and this can have security implications, or it will just partially fail. You were not able to access it on Nginx at all on port 8080, as Nginx does not has such an Alias. The only vhost specifically configured for RoundCube is on port 8081.
    ahrasis likes this.
  11. MaxT

    MaxT Member HowtoForge Supporter

    check if the symbolic links exists inside apache dir configuration. Time ago I had a similar problem because were absent:

    ls -lha /etc/apache2/conf*/*roundcube*
    lrwxrwxrwx 1 root root  /etc/apache2/conf-available/roundcube.conf -> /etc/roundcube/apache.conf
    lrwxrwxrwx 1 root root  /etc/apache2/conf-enabled/roundcube.conf -> ../conf-available/roundcube.conf
    ahrasis likes this.
  12. lnxgs

    lnxgs Member

    Hello, I've just upgrade to last version and the same happens. Roundcube does not respond on port 8080 like
    Port 8081 does not work too, never worked for me.
    I re-added the roundcube directory directive on /etc/apache2/sites-available/ispconfig.conf and restarted apache2.

    I'm going to reinstall the whole server in few days due this issue. As usual I'll install ispconfig too.

Share This Page