Running into a possible dns bug?

Discussion in 'ISPConfig 3 Priority Support' started by ledoktre, Jun 30, 2015.

  1. ledoktre

    ledoktre Member


    I have the latest version of ispconfig3 installed on Debian Jessie. I am having trouble making @ (you know, leave the hostname blank) work as a CNAME record. When I do, it renames the zone to *.err, and that of course doesn't work. Shouldn't we be able to create a root level record on a domain as a CNAME record?

    A good example of course is someone who is reselling some white label service, and to use the custom domain must use CNAME records. In this instance, it doesn't appear to be working?

    I have not yet tried this on another domain, but this one's domain is (it is not a standard .com if that matters?).

  2. Croydon

    Croydon ISPConfig Developer ISPConfig Developer

    CNAME records are not allowed for empty hosts. That's by design (not ISPConfig), not a bug (don't ask me why, but it's like that at my domain registrar, too).
  3. ledoktre

    ledoktre Member

    My registrar registered the domain regardless. The error showed up in ISPConfig3 when setting it up, not anything to do with the registrar. Seems a little bit odd that I can setup the dns zone with no @ record, and use CNAME records fine, but it errors when I add @ as a CNAME rather than an A record.

    If it is a DNS spec, that is a little bit sad too, because I can get the job done by pointing the @ record to an IP address, it just means I lose automation should the host record I was going to CNAME to changes...
  4. Croydon

    Croydon ISPConfig Developer ISPConfig Developer

    Of course, domain registration itself has nothing to do with it :) I meant the DNS of my registrar as I do not use my own DNS servers.

    Sure you can point the @ record to an IP address, if you couldn't, DNS would be useless. I don't know if the limitation of CNAME is by design of the DNS protocol or it's just bind, but anyway ISPConfig can do nothing about this, because the error is thrown by bind itself, not by ISPConfig.
  5. ledoktre

    ledoktre Member

    Somewhat disappointing. Understandable if its a spec of DNS though.

Share This Page