Samba PDC - Access Denied

Discussion in 'HOWTO-Related Questions' started by HoUsECAt, Mar 4, 2006.

  1. HoUsECAt

    HoUsECAt New Member

    I succesfully managed to get trough the great samba as PDC on ubuntu tutorial - great work!

    Only i have a problem adding my windows xp pro machine. When i want to join the domain, i have to enter login and username.. I login with my Administrator account to add the machine.

    Only i get the message : Access Denied ...

    the password for Administrator equals the one for root, isn't ?

    Last edited: Mar 6, 2006
  2. HoUsECAt

    HoUsECAt New Member

    Got a little further now

    step 1
    I believe it has something to do with rights ... because when i enter a wrong password it says : wrong username or password

    step 2
    commented the line
    invalid users = root

    now currently in the logfile i find:

    [2006/03/06 15:12:55, 3] rpc_server/srv_samr_nt.c:_samr_create_user(2330)
      _samr_create_user: winbind_create_user(clientname$) failed
    any ideas?
    Last edited: Mar 6, 2006
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    When you want to join a domain with winXP, you will have to enter the user username (not root) in the first step of the whizard and then for the second step you will have to use the Administrator login.
  4. HoUsECAt

    HoUsECAt New Member

    Thanks for your reply, i first didn't used the wizard, now it did... but it says:

    Cannot find user when i enter the Administrator + password in the second step...
    Last edited: Mar 6, 2006
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    What is the content of /etc/samba/smbusers?

    Please post the out put of the command:

    smbclient -L localhost -U%

    when you are logged in as root user (not sudo!).
  6. HoUsECAt

    HoUsECAt New Member

    in my /etc/samba/smbusers is only 1 line:

    root = Administrator
    output of smbclient

    root@adam:~# smbclient -L localhost -U%
    added interface ip=172.16.*.* bcast= nmask=
    Client started (version 3.0.14a-Ubuntu).
    resolve_wins: Attempting wins lookup for name localhost<0x20>
    name_resolve_bcast: Attempting broadcast lookup for name localhost<0x20>
    resolve_hosts: Attempting host lookup for name localhost<0x20>
    Connecting to at port 445
    Domain=[DOMAIN] OS=[Unix] Server=[Samba 3.0.14a-Ubuntu]
    dos_clean_name []
            Sharename       Type      Comment
            ---------       ----      -------
            netlogon        Disk      Network Logon Service
            print$          Disk      Printer Drivers
            IPC$            IPC       IPC Service (adam server (Samba, Ubuntu))
            ADMIN$          IPC       IPC Service (adam server (Samba, Ubuntu))
    Connecting to at port 139
    Domain=[DOMAIN] OS=[Unix] Server=[Samba 3.0.14a-Ubuntu]
    dos_clean_name []
            Server               Comment
            ---------            -------
            ADAM                 adam server (Samba, Ubuntu)
            Workgroup            Master
            ---------            -------
            DOMAIN             ADAM
    any ideas?
    Last edited: Mar 7, 2006
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Did you get any errors in your samab logfiles in /var/log/samba ?

    Are you sure you executed this command during setup?

    smbpasswd -a root
  8. HoUsECAt

    HoUsECAt New Member

    yeah i'm sure i enterend that command during setup, just did it again... same error.

    In the logfile of the client (log.clientname) i see the following... please let me know if you need to see more of the logfiles

    [2006/03/07 22:46:31, 3] smbd/sec_ctx.c:pop_sec_ctx(386)
      pop_sec_ctx (0, 0) - sec_ctx_stack_ndx = 0
    [2006/03/07 22:46:31, 3] rpc_server/srv_samr_nt.c:_samr_create_user(2330)
      _samr_create_user: winbind_create_user(clientname$) failed
    Last edited: Mar 8, 2006
  9. HoUsECAt

    HoUsECAt New Member


    i copied my smb.conf to smb.old.conf ... and copied the smb.conf from the tutorial... STUPID OF ME!! there should be a contradiction in the both.. for the fans.. i got both versions..
  10. PlanBForOpenOffice

    PlanBForOpenOffice New Member

    I had similar issues, here is what I found out

    The following line (uncommented) did give me the "Access denied" message, when I tried to join a new machine to the network and used root or Administrator to log on.
    ; invalid users = root
    This line missing from my configuration did prevent me from using the "Administrator" alias for root.
    username map = /etc/samba/smbusers
    Learned some more


Share This Page