Samba user write permissions not recognized

Discussion in 'Server Operation' started by ek59, Feb 28, 2017.

  1. ek59

    ek59 New Member

    I have a new, "simple" installation here and i can't get user write permissions to work at all.
    Centos 7 / Samba 4.2.10 / Windows 7 Professional
    pertinent info:
    security = user
    passdb backend = tdbsam
    map to guest = Bad User
    guest account = imager

    browseable = yes
    unix extensions = no
    path = /var/www/html/reports
    writeable = yes
    guest ok = yes
    write list = imager

    create mask = 0775
    directory mask = 0775
    [root@kioskserver html]# ls -l -d /var/www/html/reports
    drwxr-xr-x 8 imager imager 4096 Feb 27 12:48 /var/www/html/reports
    [root@kioskserver html]# smbstatus
    lp_load_ex: refreshing parameters
    Initialising global parameters
    rlimit_max: increasing rlimit_max (1024) to minimum Windows limit (16384)
    Processing section "[global]"

    Samba version 4.2.10
    PID Username Group Machine Protocol Version
    37951 imager imager (ipv4: SMB3_00
    37791 imager imager (ipv4: SMB2_10

    Service pid machine Connected at
    reports 37791 Mon Feb 27 15:58:30 2017

    Registered MSG_REQ_POOL_USAGE
    Locked files:
    Pid Uid DenyMode Access R/W Oplock SharePath Name Time
    37791 501 DENY_NONE 0x100081 RDONLY NONE /var/www/html/reports . Mon Feb 27 15:58:48 2017
    37791 501 DENY_NONE 0x100081 RDONLY NONE /var/www/html/reports . Mon Feb 27 15:58:52 2017

    [root@kioskserver html]#
    Windows properties on "reports" folder:

    "Everyone" and "Unix Group\imager" show only read permission. "Account Unknown" (which i assume to be Unix User/imager) shows read/write privileges. Perhaps the "Account Unknow" is causing this issue?
    OK, so here's my problem. When i try to create a new folder inside /var/www/html/reports I get a "You need permission to perform this action" error. If I change the reports folder to have group write permission, then everything works just fine. It's as if it is ignoring my owner permissions and only looking at my group permissions. This is such a basic Samba configuration but I just can't seem to get it to work. Other than telling me I'm a complete idiot (which may be true at this point), anyone have any ideas?

    Thanks so much!
    Last edited: Feb 28, 2017
  2. ek59

    ek59 New Member

    Changed owner of "reports" folder to ftp and changed all smb.conf settings from "imager" to "ftp". Widnows properties on "reports" folder now shows owner properly but still can't write to file. Owner "ftp" shows that it has "full control".

  3. ek59

    ek59 New Member

    Solved: for some reason, windows doesn't like my UID of imager which is 501. I created a new user with a UID of 1111 and everything works fine.

Share This Page