SASL authentication problems

Discussion in 'Server Operation' started by becks87, Sep 26, 2011.

  1. becks87

    becks87 New Member

    Dear Everyone,

    We have get a social institute's linux system to manage for two months ago from another IT company. Unfortunately we haven't got any documentation about it.
    Now one of our client's user phoned us, that she cannot authenticate in the mail system with the info user. They use Axigen mail system. I found that in the error log there are a lot of messages for the corresponding error:
    sasl_server_step error: 'SASL(-13): authentication failure: incorrect digest response'
    That was the first one.
    Than i found a lot of other, told me that info users password was incorrect. Also found some other:
    Authentication error [info]: Wrong SASL step
    Only one message after a few unsuccessfull login attempts: The client made 5 errors. We reject it!

    I tried the following:
    restarting saslauthd and axigen service
    Editing the config axigen.cfg to let more authentication attempts then restarting axigen service again.
    I also tried to change the user's pass with saslpasswd2 command which was successfull but the system was not accept the new pass and write another authentication failure "invalid password". Webmail and Thunderbird also not working with this mailbox, but every other still goes without errors.
    I don't know now what to do next, please help!!!
  2. falko

    falko Super Moderator Howtoforge Staff

    I think it's best to contact Axigen support about this. I don't think Axigen is widespread, so it will be difficult to find experts in a forum.
  3. becks87

    becks87 New Member

    Thanks for the advice. I talked with a linux expert yesterday and he has been taken a look at it so we found that the problem source was a bit more complex. First he found that the IMAP listener reached it's thread limit so it was the source of some errors. Additionally it wasn't making authentication failure messages to the log, so we started to distrust that it is caused by another problem. Finally i got access to Axigen mail system's web admin and i've just modified it's password to the same and click save. After that the webmail started to work but this morning they told me that the problem appeared again, so they can't logon. I looked the logs and found no authentication caused messages in the log like yesterday. I've raised the limit in the web admin for the IMAP service so webmail works again, i hope this will finally solve the problem.

Share This Page