Secondary DNS ZONE on slave server not working

Discussion in 'Installation/Configuration' started by fbarcenas, Nov 14, 2014.

  1. fbarcenas

    fbarcenas Member

    I have 2 servers with the identical setup. One is the master and one is the slave.

    From the control panel on my master server, I added a secondary DNS zone on my slave server.

    It does not show up on my slave server.

    Is it because I installed the ISPCONFIG CONTROL PANEL on my slave as well? That's the only difference between my slave install and those that they show in the guides.

    My slave server is on the allowed transfer and notify on the primary zone.
    Last edited: Nov 14, 2014
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The ispconfig interface may not be installed on slave servers, it is installed on the master only. The only exemption from that are mirroed servers but on these setups, the intarface gets manualy reconfigured to connect to the master database.
  3. fbarcenas

    fbarcenas Member

    How do I remove the ISPCONFIG CONTROL PANEL from that setup?

    Do I have to run an uninstall , then reinstall?
    Last edited: Nov 14, 2014
  4. fbarcenas

    fbarcenas Member

    OK, I ran the uninstall and reinstalled without the control panel, but I still have the same issue.
  5. fbarcenas

    fbarcenas Member

    Solved itself.
    I I ran the uninstall and reinstalled, I rebooted the server and it created the secondary zone.
  6. fbarcenas

    fbarcenas Member

    The secondary zone file on the slave server is referenced but is empty.

    zone "" {
    type slave;
    masters {x.x.x.x;};
    allow-transfer {none;};
    file "/etc/bind/slave/";

    if you go to /etc/bind/slave the directory is empty.
    Is this something to worry about?
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    did you allow zone transfers from master to slave by adding the ip of the slave in the allow transfer to field of the zone on the master?
  8. fbarcenas

    fbarcenas Member

    Yes, However, I never know which IP on the slave server is going to do the request? The slave server has 1 main and 3 virtual IPs. I've noticed that you never really know which one it's going to use, which is why I had to add all of them to the MYSQL priviledges list of users.

    Maybe that's the issue, the request is coming from one of the virtual ips instead of the main IP.

Share This Page