Secondary DNS

Discussion in 'Installation/Configuration' started by wowwen, Aug 24, 2009.

  1. wowwen

    wowwen New Member


    Ill have to start by saying, The new version is really wonderful. Great job all of you.

    I have probably done something wrong so iam looking for some guideance.

    Ive recently reinstallad my 2 servers from version 2 to the new version 3 of ispconfig ( Ive used the perfect setup for Ubuntu 9.4. The second server is connected to the first one's database. No problems here at all.

    Before i did manage each server separately, so when i created a primary dns on one of the servers, i then went in the other one and created a slave. Now, i cant seem to find the slave option. And when i try to create a zone on the other server, it says that the zone already exists.

    Have i missed something?

  2. rukus77

    rukus77 Member

    I'm not 100% sure, but based on your description, your second server is sharing the same mydns tables in your database. This may be why you get the message that the zone already exists.

    I can't confirm that this is your case 100% as my ISPConfig DB's are separate for each of my server's, but my assumption is what I've mentioned.

    What I then do from my secondary is the following;

    mydnsimport -r --axfr="primary-servername" "" (replace with your info and remove quotes)

    This takes care of creating slave zone and initial transfer.

  3. wowwen

    wowwen New Member

    Yes, that seems like the issue.

    But can i manually create that entry in the second server without harming the main database between the servers?

  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Edit the mydns config ile on the slave server and change the mysql login details in this file to point to the master server. ISPConfig is not needed for this type of replication and you dont have to add any records in ispconfig for it.
  5. wowwen

    wowwen New Member

    Perfect. That did it.

    Thanks for great support all. :)
  6. wowwen

    wowwen New Member

    Ill have to reopen this one again.

    Ive modified the settings in mydns config file to connect to the master server db. I dont get any errors when starting mydns so it has to have a connection to the other server, but when i try to run

    dig i get connection refused.

    running same command towards ns1 presents me with the correct information. Every connectionattemps towards server 2 gets connection refused, not just the zone www.mydomain.


    Ive also updated the version to
    If a run the updatescript on server2, does it still keep its connection to my master?

    [email protected]:/var/log# netstat -tap | grep dns
    tcp 0 0 ns2.mydomain:domain *:* LISTEN 26583/mydns
    tcp 0 0 localhost.locald:domain *:* LISTEN 26583/mydns
    tcp 0 0 ns2.mydomain.:50730 ESTABLISHED 26584/mydns
    tcp6 0 0 localhost:domain [::]:* LISTEN 26583/mydns

    [email protected]:/var/log# dig
    ; <<>> DiG 9.5.1-P2 <<>>
    ; (1 server found)
    ;; global options: printcmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: REFUSED, id: 56514
    ;; flags: qr rd; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0
    ;; WARNING: recursion requested but not available

    ; IN A

    ;; Query time: 2 msec
    ;; SERVER:
    ;; WHEN: Fri Oct 2 01:51:05 2009
    ;; MSG SIZE rcvd: 26
  7. wowwen

    wowwen New Member

    Problem Solved :cool:

    I had to change the server ID in the mydns.conf

Share This Page