Secure proftp by using tls

Discussion in 'Tips/Tricks/Mods' started by tom, Nov 6, 2006.

  1. tom

    tom Member

    I'm wondering myself why proftp with tls is not standard in ISPconfig but I'm verry interested how to make the ftp connection secure. All password passwords are sended as plaintext. Right?

    Do you now a good howto for making proftp secure by using tls?
  2. tom

    tom Member

    Ok, I just worked it out:

    Make your proftp secure by using tls

    # look for compiled moduls:
    /usr/sbin/proftpd -l
    # if not --> compile proftp with tls :

    # create ssl-certificate
    # change proftpd.conf tls according to

    # restart proftp
    /etc/init.d/proftpd restart

    # The ftpclient (with the abillity to use tls) should show that while connecting:
    ## that’s all :)
    Syntax: TLSRequired on|off|ctrl|data
    #Don't use a specific ssl certificate. To start you shold use that
    TLSRequired off

    # Require SSL/TLS on the control channel, so that passwords are not sent
    # in the clear.
    TLSRequired ctrl

    # Require SSL/TLS on both channels.
    TLSRequired on
    Last edited: Nov 7, 2006
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    Thanks for the Howto. I moved it to the Tips & Tricks forum.
  4. tom.1

    tom.1 New Member

    Make it work with ISPConfig

    Since this post regards ISPConfig someone should mention that the

    <IfModule mod_tls.c>
    </IfModule> ​

    should be written into /etc/proftpd_ispconfig.conf

    To make it really work you should add

    PassivePorts 60000 60100 ​

    (or any range you like) before <IfModule mod_tls.c> and open the respective ports in your firewall.

    The background is, that the firewall can't inspect the encrypted traffic and therefore can't determine the passive ports the filetransfer will take (and hence can't open them). With the above settings you will force proftpd to take the specified ports which you opened in the firewall.

    At least that's the way that finally worked for me.

Share This Page