Segfault on Fedora 8 with ISPConfig 2.2.32

Discussion in 'Installation/Configuration' started by clanx, May 29, 2009.

  1. clanx

    clanx New Member


    My system as follows :

    Fedora Core 8 (End of life - I know)
    PHP 5.2.6
    ISPConfig 2.2.32
    MySQL 5.0.45
    BIND 9.5.0-P2

    The Problem :

    I found that emptying recycle bin in DNS Manager wont work. I have several domains lying around in the bin but upon emptying nothing happens.

    The domain still exist in recycle bin.

    Error Logs

    I notice the following when running php from the command line

    [[email protected] ispconfig]# /root/ispconfig/php/php -q /root/ispconfig/scripts/writeconf.php
    Segmentation fault

    So I have check the log files below.

    Nothing is showing in my ispconfig.log error logs but some INFO message appers :
    Mean while my /var/log/messages shows a scary error message

    What to do next ?
    Any advise ? If possible I need to clear off the old DNS entries in recycle bin in order to add new DNS name. This is a priority.

  2. clanx

    clanx New Member

    Allright, after further checking, I found that my settings for DNS is not what it should be

    Under Management -> Server -> Settings -> DNS, Zonefiles Dir. shows to invalid path /etc/bind

    No idea how, when and who changed it.

    I believe it should be pointing to /var/named/chroot/var/named

    So I decide to change it and hit the save button but ISPConfig still shows the old settings, seems no update is getting saved on the system.

    Again check the logs files reveals me the same error :

    Any suggestions ? I guess the real problem lies on the incorrect Zonefiles pointing that causing segfault issue.

    Appreciate some advise.
  3. clanx

    clanx New Member

    Ok, I answering to my own problem now.

    Thank lord manage to get the issue fixed.

    So FYI to everyone who get segfault issue on FC8 or equivalent, the root caused of the problem is because your ISPConfig config file is not properly setup. Example in my case DNS Zone file is pointed in wrong folder.

    So the solution to this is to change some permission, restart named and re-edit the DNS settings and magically it get saved this time.

    Here is the step

    1. Change permission on named, just to make sure permission is in place
    2. Restart named service to take effects on the permission changes (if any)
    3. Go to Management -> Server -> Settings -> DNS, Zonefiles Dir. and change the setting to :

    save it.

    As for now, no more segfault issue and my web server is back to working condition.

    P/s : Still I'm curious how my Zonefile settings somehow change it self, either because of ISPConfig upgrade ? Maybe FC users out there can share if you face the same problem.

  4. falko

    falko Super Moderator ISPConfig Developer

    When exactly do they change? I guess it was a permissions problem and should be fixed now because of what you did in step 1.

Share This Page