segmentation fault on clamd

Discussion in 'Server Operation' started by beufert, Sep 4, 2010.

  1. beufert

    beufert New Member


    I have been racking my brain and the search engines for an answer to this, i recently installed postfix as per when I get to step number 9, the part of restarting clamav-daemon. I receive this message:

    home:~# /etc/init.d/clamav-daemon restart Stopping ClamAV daemon: clamd.
    Starting ClamAV daemon: clamd /etc/init.d/clamav-daemon: line 308: 5002 Segmentation fault start-stop-daemon --start -o -c $User --exec $DAEMON

    What could be the cause of this message.? Could it be hardware related like memory faults.

    home:~# cat /proc/cpuinfo
    processor : 0
    vendor_id : AuthenticAMD
    cpu family : 6
    model : 10
    model name : AMD Athlon(tm) XP 2400+
    stepping : 0
    cpu MHz : 1998.198
    cache size : 256 KB
    fdiv_bug : no
    hlt_bug : no
    f00f_bug : no
    coma_bug : no
    fpu : yes
    fpu_exception : yes
    cpuid level : 1
    wp : yes
    flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 mmx fxsr sse syscall mmxext 3dnowext 3dnow up
    bogomips : 4001.35
    clflush size : 32
    power management: ts

    If any other info is needed, i'll be glad to post it.
    Thank you for any suggestions and help and if posted this in wrong forum, i apologize.
  2. falko

    falko Super Moderator ISPConfig Developer

    At least I can't rule out hardware faults. Try to run memcheck.
  3. beufert

    beufert New Member

    i have tried memtest86

    memtest86 and memtest86+ both go through test overnight fine, but i haven't used memcheck itself before, i don't even know how to use that one.
  4. falko

    falko Super Moderator ISPConfig Developer

    These are fine.

    Not sure what is wrong. Did you try to reinstall clamd?
  5. beufert

    beufert New Member

    reinstall clamd - same error

    i just figure to bypass clamd for now but on another note, may be related. I also notice that when creating quota patch, when i get to dpkg-buildpackage. I also get
    mkmap_open.c: In function âmkmap_openâ:
    mkmap_open.c:212: internal compiler error: Segmentation fault
    Please submit a full bug report,
    with preprocessed source if appropriate.
    See <file:///usr/share/doc/gcc-4.3/README.Bugs> for instructions.
    make: *** [mkmap_open.o] Error 1
    make: Leaving directory `/usr/src/postfix-2.5.5/src/global'
    make[1]: *** [update] Error 1
    make[1]: Leaving directory `/usr/src/postfix-2.5.5'
    make: *** [build] Error 2
    dpkg-buildpackage: failure: debian/rules build gave error exit status 2

    Could this be related? If not how may i repair that error.

    Thanks for helping me out. I appreciate it.
  6. falko

    falko Super Moderator ISPConfig Developer

    Not sure why this happens. I think I'd try a reinstall, and if that doesn't help, maybe you should try another hard drive.
  7. beufert

    beufert New Member


    I will try that, i have suspision that its both HDD and my RAM since i have already replaced MB and this new MB requires different type Of Ram, closed for now.

    I appreciate it.

Share This Page