Sending audio to bluetooth speaker

Discussion in 'HOWTO-Related Questions' started by axslinger, Jun 1, 2017.

  1. axslinger

    axslinger New Member

    Greetings! I'm hoping I can get a little direction on my bluetooth speaker issue...
    My setup: Raspberry Pi 3B with Raspbian Jessie, updated and upgraded. Current kernel
    On-board BT, WiFi, Ethernet, 4-USB ports, HDMI, analog audio/composite video. Currently WiFi is disabled as the BT and WiFi don't work well together. Using hardwired Ethernet.
    My goal is to use this as a media center. My audio over HDMI works fine into my TV but I don't have speakers in my monitor and I want to be able to hear audio as I'm tweaking/testing KODI.

    I've followed the tutorial on the tutorials page, as well as some other that are similar, but still having issues.
    Here is the order I follow:
    # power on
    # agent on
    # default-agent
    # scan on
    I see my device, Aomais II Sport Speaker...
    # pair *my MAC address*
    # connect *my MAC address* (Speaker responds with "paired")
    So far, so good.
    I go to pavucontrol and I see it as an option and set it as the fallback device. I open KODI and sometimes I'll hear the KODI audio cues. I go to play an MP3 and it plays for about 3-5 seconds then stops.
    I exit KODI and open pavucontrol and my speaker is no longer listed.
    I open Blueman and my speaker is still there but if I select it or try to do anything with it, Blueman hangs and I get the generic "hung app" message. At this point, bluetooth for audio is toast although my bluetooth keyboard still works fine. Even if I kill the bluetooth task and restart the service, Blueman is still hung and I can't even do anything in 'bluetoothctl'. It basically says it's busy. Can't remember the exact verbiage.
    I'd like to be able to tell you everything I've done but I've tried so many things, I don't know where to start. In addition to following the tutorial on this site, I've also tried all the steps listed on the archlinux wiki for bluetooth headsets. (That's basically how this is seen since it also has a built-in mic and can take calls).

    One thing I have noticed is when I've stayed in bluetoothctl, I can see my connection status for the speaker go from yes, to no to yes to no and then it finally hangs and I get "*mac address* :RSSI n/a" or something to that effect.

    If you could direct me to the pertinent log files/systemctl logs, etc. I might be able to get some hints as to what's going on.
    Thanks in advance.


Share This Page