Sending mails via Windows Mail not working

Discussion in 'Installation/Configuration' started by milli727, Mar 31, 2021.

  1. milli727

    milli727 New Member

    I am struggling for days now trying to figure out why mails sent from my windows Mail client stay in outbox. After checking a lot of thread I couldn't find a solution for my problem.
    Can anyone please help?

    System information:
    OS-Version: ubuntu 20.04
    ISPC-Version: 3.2.3 (Using Perfect Server Setup)
    Plugin: Automail

    Sending/receiving mails via roundcube works absolutely fine. Microsofts connectivity says that everything is working fine.
    The problem is, that I cannot send mails using my windows 10 mail client. I do receive them but when I try to answer them, they're stuck in the outbox.

    Note: I have replaced my domain with example[.com]
    ISPC-Location: Port: 8080
    E-Mail I am trying to send with: coffee@example[.com]

    (I am sorry, but I can't embed the images directly. I will embed them when I reached my 2 Post minimum)



    Mar 31 14:09:31 server1 postfix/smtps/smtpd[12473]: SSL_accept error from[MY_IP]: Connection reset by peer
    Mar 31 14:09:31 server1 postfix/smtps/smtpd[12473]: lost connection after CONNECT from[MY_IP]
    Mar 31 14:09:31 server1 postfix/smtps/smtpd[12473]: disconnect from[MY_IP] commands=0/0
    Domain Configuration:
    Last edited: Mar 31, 2021
  2. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    0 commands does not match your screenshot smtp session, there should be at minimum 2 ehlo and 1 starttls which the smtp server responded to. Also the logs are for 'smtps' (port 465), which does not use nor make available the STARTTLS command. Perhaps your mail client is not talking to that server? Or maybe you grabbed logs for the wrong smtp session.
    milli727 likes this.
  3. milli727

    milli727 New Member

    Thanks for your fast reply.

    The smtp session I posted was from tool which checked the smtp configuration, ensuring that the certificates are setup well. The logs I posted are from my Windows 10 default mail program, trying to send the e-mail.

    According to Wireshark, my mail Program is talking to Port 465 using TLSv1.2.
    Also the destination IP is correct so my Mail Client is talking to the correct server.
    Last edited: Mar 31, 2021
  4. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    Your wireshark output would correspond to the mail logs - your client reset the connection during tls negotiation. Does your mail client have any updates? I think we mainly see ssl/tls issues on older windows clients, but I don't really deal with that end of things. Try searching for your mail client name and maybe version number with "tlsv1.2" or similar.
  5. milli727

    milli727 New Member

    Thanks for your reply!
    I am using Windows 10 default Mail Client by Microsoft which every Windows 10 version has. (It is up-to-date)
    It does support TLSv1.2.
    I also cannot explain the problem because everything looks configured properly...
  6. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    How have you configured the outgoing e-mail server on your Windows 10 mail client?
  7. milli727

    milli727 New Member

    I've just tried that, it works. But customers should be able to only enter their mail and their password, see below (This works with Plesks IMAP)
  8. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    Every mail client allows you to set a name for sending.
  9. milli727

    milli727 New Member

    Solved the problem. It was the MX entry.
    Thanks for your help and time!

Share This Page