Server Not Autorative for Domain Error

Discussion in 'Installation/Configuration' started by drbista, Dec 15, 2005.

  1. drbista

    drbista New Member

    I created a domain with the ISPConfig Control Panel. I pointed another domain ( to the DNS of the that was provided by the webhost for the server. I certainly checked 'create DNS' and 'create DNS MX' while creating subdomain. Now the problem is it gives DNS error when I point the domain to the server. The error message is as follows:

    When I checked what it means, the gave an explanation to this error as:

    What could be the problem? I am going to point all other domains that I register to the same IP so that I could share the webspace as virtual domains in the shared space. Thanks!

    With warm regards,
  2. falko

    falko Super Moderator Howtoforge Staff

    This is what I found out:

    This means that the authoritative name server for is, so you either have to create (or have someone create) the records on that server, or you tell you registrar that you'd like to switch the authoritative name server for that domain to another one (yours), and afterwards you can create the records on your name server.

    Please have a look at this thread:
  3. drbista

    drbista New Member

    Tried, but without success

    Dear Falko

    It is already 2 weeks that I am trying to change that directly in the's control panel. And the error messages are from their servers. It said that I have to create a DNS entry in the my remote server, which I hope I already did while creating the new domain.

    It is worth mention what the "DNS is not found in the Zone" means, according to (people at are not physically available):

    The thread you pointed to me gave me a good explanation, but directi has a better control panel. also has the same, but it keeps on repeating the same error. They say I have first to create a DNS entry on my server instead.

    So, I am just confused! :confused: Shall be obliged if you elaborate a bit!
    Last edited: Dec 16, 2005
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Hve you set the promary and secondary DNS Server correctly in ISPCOnfig for this Domain in the DNS-Manager? The primary DNS must be a domain already pointing to your DNS Server and the secondary must either point to your Server too or any other server you are able to use as secondary DNS.
  5. drbista

    drbista New Member

    Thank you! But what is the FTP server?

    Dear Falko and Till:

    Thank you so much. I thought that when I click on the "create DNS" and "create DNS MX" while creating the site, it would automatically create the DNS entry. But I came to know that I have to manually create a DNS entries in the DNS Manager. Thanks a lot.

    Now my other question is what is the remote ftp login for Is it or something else. And whether the username is something like the [email protected] or webX_user?

    Thank you again!
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Generally it is not nescessary to setup the DNS records in DNS-Manager manually, if you setup the defaults in management > Server > Settings correct. But its always better if you check the records in DNS manager.

    ftp login domain is the domain you setup. If you dont setup in DNS manager, it will be or

    Usernames are webX_user
  7. falko

    falko Super Moderator Howtoforge Staff

    In general, you can use any FQDN that points to your server, you can even use its IP address. :)
  8. drbista

    drbista New Member

    Weird situation!

    Dear Falko and Till:

    H2F is superb and your collaboration.

    In the meantime, let me give you a weird situation that I am encountering.

    I could access the control panel at and also by ssh, but the domains that I created like and does not get rendered in the browser at times. What could be the problem?

    This is the second time that I encountered a similar problem. Any clue?
  9. falko

    falko Super Moderator Howtoforge Staff

    What do you mean with "does not get rendered"? When I go to these sites, I see the normal ISPConfig index page so everything seems to be ok.
  10. drbista

    drbista New Member

    Continuing Hurdles

    Dear Falko:

    1) I tried using both IE and FireFox but both says that server is not found at my end and the placeholder does not simply appear in my laptop. Just wondering about this behavior. And this continued again (seems problem with the Internet provider)

    2) I have also disabled the firewall and checked again. Even FTP access is not allowed, saying can't resolve hostname.

    3) I checked with another computer also. gave me shared IP default page of ISPConfig and the gave me the pageholder. However, I don't know what could be the problem? After adding a codomain pointed to the same IP, it rendered me the page.

    4) Tried to create a subdomain like subdomain.domain.tld by adding 'subdomain' as host and 'domain.tld' as domain in the codomain tab and also checked both create dns and create dns mx and saved. But pointing to subdomain.domain.tld does not render anything. Or this is the wrong way of creating a subdomain inside a domain?
    Last edited: Dec 20, 2005
  11. falko

    falko Super Moderator Howtoforge Staff

    Seems to be a problem with the DNS servers you're using on your laptop because it is working fine for me. Can you try these name servers on your laptop: and

    I guess you created a web site without the Co-domain Technically, and are two different addresses, that's why you explicitly have to add as a Co-Domain if you want to access the web site for when you type in in your browser.

    That's the correct way. Again, I think it's a problem with the DNS servers you use on your laptop.

Share This Page