SFTP on Ispconfig

Discussion in 'General' started by Gino Carpanetti D., Nov 29, 2016.

  1. Gino Carpanetti D.

    Gino Carpanetti D. New Member

    Hello everyone,
    I'm triying to manage a SFTP connection to my ubuntu server running Ispconfig. I just want to have more control over files and download manually stuff when i need it.
    I can't login via WinSCP with the root user (i can imagine why, security) and i messed up a VM playing with "chown" so i hope someone can help me by telling me the correct way to do this, safe and formal.
    Should i create a user in the root goup? (Didn't work in my first try)
    Should i use puteFTPD virtual users?
    I just want to be able to manually download all sensitive information (vmail, /etc, databases, etc) and do it in an safe and professional way.
  2. sjau

    sjau Local Meanie Moderator

    if you use debian, by default root login with password is disabled. No idea about other distros.

    To change it (on debian) edit /etc/ssh/sshd_config and set
    PermitRootLogin yes
    Afterwards restart ssh/d
  3. Jesse Norell

    Jesse Norell Well-Known Member Staff Member Howtoforge Staff

  4. sjau

    sjau Local Meanie Moderator

  5. Gino Carpanetti D.

    Gino Carpanetti D. New Member

    Tank very much, changing the PermitRootLogin to 'yes' worked. I'll check the other solution too.
    I could backup all files but i had trouble with the Ispconfig database because i cannot log in to phpmyadmin as root or any "normal" Ubuntu user to export it, it gives me the error 1045. It does not throw that error for normal users os the hosting. All clients can work perfectly.
    Do you know how can i fix it? Or i am suposed to backup the databes by other means. The error is thrown in mysql to.
    "mysql -u root -p" doesnt work either.
    There are ways to fix that on the Internet but i don't want to messed the Ispconfig instalation so i haven't tried yes since they are for general ubuntu instalations.
    Thanks very much.

Share This Page