So close but yet so far. (Setup error)

Discussion in 'Installation/Configuration' started by Art Garfunkle, Sep 2, 2005.

  1. Art Garfunkle

    Art Garfunkle New Member


    I got through most of the setup but got kicked out after entering my mysql info.

    Here's where I am:

    Preparing files. Please wait a moment...
    All prerequisites are fulfilled.
    Here we go...
    Please enter your MySQL server:
    Please enter your MySQL server:localhost
    Please enter your MySQL user:root
    Please enter your MySQL password:
    Please enter a name for the ISPConfig database (e.g. db_ispconfig):db_ispconfig
    Please enter the IP address of the ISPConfig web (e.g.
    Please enter the host name (e.g. www):mainle
    Please enter the domain (e.g.
    ERROR: The URL is not reachable! The installation routine stops here!

    OK, I probably entered the wrong domain name; and am willing to try again.

    BUT do I have to start from the beginning again? :confused: Please say no!

    That would be a royal pain. And what if I get the domain wrong again?!

    Is there a way to test that I have the correct domain?

    Is there some way to start where the installation left off?


  2. ahuen

    ahuen New Member


    I got the same problem and here is the resolution. for the hostname leave it blank and for the domain name enter your ip address. it worked for me.

  3. Art Garfunkle

    Art Garfunkle New Member

    Thanks Al! :)

    But do I have to start all over again or is there some way to pick up where I left off?


  4. ahuen

    ahuen New Member


    i think you have to start over.

  5. till

    till Super Moderator Staff Member ISPConfig Developer

    Yes, make shure you delete the install_ispconfig directory and unpack the installer tar.gz again. If you want to test your domain before:

    your host is: server1
    your domain is:

    When you can make a

    the installation will proceed.
  6. Art Garfunkle

    Art Garfunkle New Member

    Hi Till,


    OK I followed your suggestions (above), deleted the install_ispconfig directory and unpacked the installer tar.gz again and re-installed.

    This time, things seemed to go OK. It never asked for my domain and never offered to install in Advanced mode. But other than that it seemed to work OK.

    At the end, it said it had succeeded.

    BUT. I can't get to the administrator.

    https://<hostname>:81/ doesn't work. Nor does

    I did find the correct hostname via ping <hostname>. It pinged!

    In all attempts I get "Cannot connect to host <hostname/localhost> (port 81)."

    Also, when I try to follow the installation instructions to set up SpamAssassin, I run into an error at the command: "install DB_File". Here is the text of the error:

    gcc -c -I/usr/local/BerkeleyDB/include -DPERL_DISABLE_PMC -fno-strict-aliasing -pipe -I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 -I/usr/include/gdbm -O2 -fomit-frame-pointer -pipe -march=i586 -mtune=pentiumpro -DVERSION=\"1.811\" -DXS_VERSION=\"1.811\" -fPIC "-I/usr/lib/perl5/5.8.6/i386-linux/CORE" -D_NOT_CORE -DmDB_Prefix_t=size_t -DmDB_Hash_t=u_int32_t version.c
    version.c:30:16: db.h: No such file or directory
    make: *** [version.o] Error 1
    /usr/bin/make -- NOT OK
    Running make test
    Can't test without successful make
    Running make install
    make had returned bad status, install seems impossible

    What I can do to figure out what went wrong?

    Thanks for your help,

  7. falko

    falko Super Moderator Howtoforge Staff

    If the ISPConfig installer didn't ask anything than it was in update mode which means it found an existing installation and updated it. You can try to set your correct host/domain in /home/admispconfig/ispconfig/lib/ If that doesn't help, uninstall ISPConfig:
    and install a new ISPConfig.

    You might have to install some Berkeley db packages first, like this:

    apt-get install db-devel
    apt-cache search db
    to find available packages to install.
  8. Art Garfunkle

    Art Garfunkle New Member

    Hi Falko,

    Many thanks!

    .../ispconfig/uninstall didn't exist on my system. Probably do to difficulties in the installation. I renamed /root/ispconfig and /home/admispconfig and the new installation went flawlessly. Thanks!

    That worked. Thanks again.

    Now I can get to the login screen with https://<my hostname>:81/ but I have no idea what my user name and p/w are. I don't think I was ever asked.

    I tried root/<my linux p/w> and root/<my mysql pw>. Neither worked.

    I guess there must be a default in order to get started, but what is it??? :confused:


  9. palkat

    palkat New Member

    your default ispconfig login is:

    login: admin
    pass: admin
  10. Art Garfunkle

    Art Garfunkle New Member

    Thanks palkat,

    I ended up changing the password in the sys_user table.


  11. till

    till Super Moderator Staff Member ISPConfig Developer

    The default passwords are all listed in the documentation :)
  12. rupurt

    rupurt New Member

    on my install i specified the host as server1 and the domain as

    i can only log onto my system through the local network i.e

    i tried but this doesnt work.

    What do i have to put into the server list of my domain name registrar?

    thanks all

    EDIT: i am behind a NAT so how does the internet know what the address of my computer is??
  13. falko

    falko Super Moderator Howtoforge Staff

    Does resolve to your public internet address (the one your router has towards the internet)? Does your router forward port 81 to your ISPConfig box?
    Even if you answer these 2 questions with yes it might be that you can access ISPConfig by using because your router doesn't forward you because he knows that you're already in the local network. There was another thread about this in the forum, you might have to search a little bit to find it.
    But you can use the IP address instead, you only have to change /home/admispconfig/ispconfig/lib/ then.
  14. rupurt

    rupurt New Member

    ok ive come into another problem when i log in using and i click any of the operations that ispconfig is meant to be able to do i tries to load them from
    So the pages dont load?

    i have forwarded port 81 for the server box.

    i am a bit confused about where i need to put my external ip! the one that my router has. where about do i need to add that? because whenever it asked me for an ip i just put the local one in

    do i need to setup a dynamic dns or something and put that in the domain registrars nameserver field?

    thanks again guys
    Last edited: Sep 21, 2005
  15. till

    till Super Moderator Staff Member ISPConfig Developer

  16. shellNewbie

    shellNewbie New Member

    Wish I had seen this thread 3 days ago.

    Horrible place to be stuck at. But all is well that ends well :eek:

Share This Page