So much for virtual hosting...

Discussion in 'Installation/Configuration' started by incgnito, Jan 13, 2007.

  1. incgnito

    incgnito New Member

    I'm probably about to give too much information but it's probably better than not enough so here ya go... :p

    I had a working ISPConfig setup as per the Ubuntu 6.10 guide here (excellent guide, btw) -- until tinkerbell here (a.k.a yours truly) decided to change the network around a bit and now I seem to be screwed! My original setup had an Ubuntu server (IP 192.168.x.254) behind a m0n0wall router (192.168.x.1) along with my other various machines (192.168.x.2-5). Well due to hardware issues (and complaints from the wife to clean up my damn mess) I removed the m0n0wall box from the equation (it's hardware is identical to the server and the server box was having issues, so I swapped drives) and the server took on the role of the router as well (it's IP changed to .1). Before the move after adding entries in the local hosts file of the PC's I could access all of my three domains I had set up and configure them without issues. Now after the move locally I can only access one of the domains properly (and yes I changed the hosts files accordingly); the other two bring up an ispconfig "shared IP" error page. Mail for the domains seems to be unaffected. Now today a customer was nice enough to call me and let me know that none of the websites are visible from outside the router; they all display the / directory and browsing to the webs only shows the contents of the php files as if they're text.

    Wonderful... :confused:

    Now one thing I noticed is that if I have the PC's set to use the server box's DNS server and ping my domain it pings the old local IP (.254) despite the hosts file pointing to .1. Unfortunately I don't know enough about bind to do anything about it short of removing it and reinstalling. I suppose I could back up the webs, wipe, and reinstall everything but I really would like to figure this out -- formatting & reinstalling is the easy way out!

    Any ideas or suggestions would be greatly appreciated.
  2. martinfst

    martinfst ISPConfig Developer ISPConfig Developer

    I assume you have rebooted the systems involved. As you have changes IP addresses, every component in your network has to become aware something is changed. The relation between hardware and IP addresses is maintained in so called 'arp' chaches. Next is left over routes that may still ebe present somewhere. You can check your system with
    # arp
    # route -e
    and see if you have any old (and wrong) information. Please do so on every component you control, including you gateway/router. (have you rebooted this as well?)
  3. incgnito

    incgnito New Member


    Nothing from 'arp' seems out of place, and the only entry from 'route -e' that I don't recognize is:

    Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface       *            U         0 0          0 eth1
    Any other ideas guys?
  4. incgnito

    incgnito New Member

    Quick question

    Something I just thought about: now that the machine is connected directly to the outside should I set up the IP in ISPConfig for the server to reflect the external IP? Like I said, just a thought...
  5. martinfst

    martinfst ISPConfig Developer ISPConfig Developer

    There are several posts in the forums about changing the IP address of a server running ISPConfig. So yes, you need to do several steps to get ISPConfig to function as intended.
  6. incgnito

    incgnito New Member

    So in other words, RTFM...

    Thank you at least for being nice about it. I'll research and get back to you... :eek:
  7. falko

    falko Super Moderator ISPConfig Developer

  8. incgnito

    incgnito New Member

    Thank you

    Falko you always seem to be the one to help me when I run into issues -- unfortunately I'm an impatient person, so I spent the night last night 1)Formatting/reloading the server to function as a gateway and G4L backup server (learning Shorewall along the way), and 2)Loading the server via the HTF guide as a vm on my wife's machine which she never uses until I build another one(I won't tell her if you don't :p ), so if anything happens again I can just hit the 'revert snapshot' button (as I seem to be accident prone).

    Looking at what you gave me though, it looks like it would've worked fine... :rolleyes: . Oh, well. Thanks for the effort, though!

Share This Page