Solution: rspamd bayes <-> redis issue (noauth ...)

Discussion in 'Installation/Configuration' started by Moppi79, Apr 24, 2024.

  1. Moppi79

    Moppi79 New Member

    sorry, can't answer in the "Priority Support" section.
    A user asks for a solution for his rspamd noauth problem for bayes here:

    The problem is already known to rspamd, and there is an not yet solved github entry for that.

    The solution is to add the password line for redis also in the /etc/rspamd/local.d/classifier-bayes.conf configuration.

    backend = "redis";
    servers = "";
    password = "xxxxxxxxxxxxxxxxxxxxxxxxxxxx";
    autolearn {
    After a restart of rspamd, the errors disappear.

    Best regards
    till and like this.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Thanks, I've added a link in the original thread.
  3. Stelios

    Stelios Active Member HowtoForge Supporter

    I've tried that and it doesn't work. I solved the issue by adding a second instance of redis without a password just for the particular config.
    The initial redis is reserved from nextcloud which is also running on same server.
    Thanks anyway!

Share This Page